Description

When you try to activate your NiceLabel license, the activation stops and reports an error with this title: “We cannot check your license.”

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Causes

Cause 1: Firewall settings are blocking your connection. The NiceLabel licensing server checks if your license is active and valid. This is why the connection between your computer and the NiceLabel licensing server is mandatory. If there is no connection, you cannot activate your NiceLabel NiceLabel 10.

Note

The NiceLabel licensing server issues and activates the purchased licenses.

Cause 2: The NiceLabel Proxy Service 10 has stopped. If you own a multi-user license, your installed NiceLabel applications use the NiceLabel Proxy Service 10 to communicate the licensing information. If this service stops on one of the computers, the installed copy deactivates.

Solution

  • For Cause 1, check your firewall settings. Make sure port 6772 is open.

Note

Consult your IT personnel for the firewall settings.

  • For Cause 2, restart the NiceLabel Proxy Service 10:

  1. Open Services on your computer.

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    If the issue with this service persists, try to run the service with your local system account. Right-click the service and go to Properties > Log On tab. Log on using the Local System Account.

  2. Search for NiceLabel Proxy Service 10.

  3. Right-click the service and click Restart.

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    Note

    If the issue with this service persists, try to run the service with your local system account. Right-click the service and go to Properties > Log On tab. Log on using the Local System Account.

  4. Repeat the license activation procedure.