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1. About NiceLabel Control Center
NiceLabel Control Center allows you to manage your entire label printing system from one place securely.
For businesses, small or large, it helps save time, reduce errors and costs, and increase efficiency in your
label printing processes.

With Control Center you can:

• Produce consistent and compliant labels.

• Monitor, analyze, and improve your label printing processes.

Web-based access allows you to manage users, groups, printing applications, and integrations for your
system without maintaining any IT infrastructure. Depending on your operational needs, you can also install
Control Center on-premise in your IT environment as part of NiceLabel Label Management System.

Control Center helps different individuals manage and use your labeling system:

• Global IT Administrators manage global security, access, and synchronization while centrally
monitoring labeling in multiple locations.

• Local IT Administrators install, configure, test, and solve problems in single locations to keep
production running.

• Label Designers create and test documents, applications, and integrations and use workflows and
print management for your label templates.

• Quality Assurance Managers approve changes in workflows, get reports, ensure regulatory
compliance, and reduce risk.

• Operations Managers standardize print processes and get production data to identify ways to
improve efficiency and avoid errors.

Control Center is available as part of the following NiceLabel products:

• NiceLabel LMS Pro/LMS Enterprise (on-premise):

• NiceLabel Control Center is a cloud-based application that allows you to share and store your
labeling files and print labels. Control Center connects all printers of all users who have their
Desktop Designer connected to Control Center.

• NiceLabel Web Printing is a web application that is part of Control Center. Web Printing allows
you to centrally deploy your labels from Control Center's storage.

• NiceLabel Desktop Designer is an application for designing and printing labels. Install Desktop
Designer on your computer and connect it to Control Center. In Control Center, you can see all
your printers connected to your Desktop Designer.
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• NiceLabel Print is a stand-alone application for fast and easy printing, without the need for
opening labels in Desktop Designer.

• NiceLabel Automation Pro/Enterprise is an application that automates repetitive tasks like
automated printing.

• NiceLabel Web Client is an application to access and use your labels, shared in Control Center.

1.1. Using Control Center
Open NiceLabel Control Center from your browser to start centrally managing your entire label printing
system from one place. Your Dashboard is your starting point for managing your label printing system
centrally from Control Center.

1. Open Control Center:

• For Label Management System, open http://yourserver/epm. Replace yourserver with
your installation server name. For first -time sign in information, read Section 2, “On-Premises
Installation”.

2. The Control Center sign-in page opens. Sign in with your Microsoft or Google account.

When you sign in, your Dashboard opens:

Your Dashboard gives you an overview of your entire labeling system:
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1. Recent Printing Activity (Last 24 hours) includes which computers printed, print counts, times, and
errors.

2. Recent Errors (Last 24 hours) include error types, modules, computers, users, statuses, and
submission dates.

3. Computers Running Automation includes all your computers running NiceLabel Automation.

4. Common Activities include links to frequently-performed Control Center actions like Print from your
Applications and Add New Managed Printer.

5. Waiting for your Approval includes files in workflows shared with you to review and approve or
reject.

6. License Information includes product information and the number of printer seats you're using.

7. Server Information includes Control Center server name and server time.

Use the menu on your left to open other Control Center pages:

NOTE
You can hide Control Center pages for your users by updating user Access Roles.

1. Dashboard

2. Documents

3. Applications

4. Integrations

5. Printers

6. History

7. Analytics

8. Users

9. Administration

See important information about your entire labeling system on your Dashboard when you open Control
Center.

1.2. Display Language
Control Center is a web application that runs in your browser. To change the language of your Control
Center user interface, you must manually change language preferences in your browser (or your system for
Microsoft Internet Explorer).
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NOTE
Before you change your display language, make sure your language is available in Control
Center.

1.2.1. Google Chrome

In Google Chrome, you change your display language in browser settings.

If your preferred language is not available, Control Center displays in English by default.

TIP
If your preferred language is not available, Google Chrome can temporarily translate pages
into your preferred language.

To change your Control Center display language in Google Chrome, do the following:

1. On your top right, click Customize and control Google Chrome ( ) > Settings.

2. Go to Advanced > Languages.
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3. Click Language to expand language options. Find your preferred language and click More actions
( ) > Display Google Chrome in this language.

If your preferred language isn't listed, click Add languages. Select your preferred language from the
menu and click Add. Your new language is now listed (at the bottom of your list), but your preferred
language is still not set. Repeat step 3 to set your added language.

4. Click Relaunch to restart Chrome and apply your changes.
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NOTE
Refresh your browser and reopen Control Center to apply your changes.

Your Control Center user interface now displays in your preferred language.

1.2.2. Microsoft Edge

In Microsft Edge, you change your display language under browser settings.

If your preferred language is not available, Control Center displays in English by default.

NOTE
You must sign in to your Microsoft Edge to change your browser's display language.

To change your Control Center display language in Microsoft Edge, do the following:

1. Go to Settings and more (  or Alt+F) > Settings.
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2. Click Languages.
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3. Next to your preferred language, click ( ) and choose Display Microsoft Edge in this language.

If your preferred language is not on your list, click Add languages. Select your language from the
dropdown list. Click Add.

4. Click Restart to apply your language change.
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NOTE
Refresh or reload your already opened tabs containing Control Center to apply your
change.

Your Control Center user interface now displays in your preferred language.

1.2.3. Mozilla Firefox

In Firefox, you change your display language for multilingual web applications and pages under browser
options.

If your preferred language is not available, Control Center displays in English by default.

NOTE
Firefox also allows you to only change your display language for your Firefox interface. This
method does not affect your Control Center display language.

To change your Control Center display language in Mozilla Firefox, do the following:

1. On your top right, click menu ( ) > Options.
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2. Scroll down to Language and Appearance > Language.
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3. Next to Choose your preferred language for displaying pages, click Choose....

4. Change the order of your webpage display languages. Place your preferred language at the top of
your list.

If your preferred language is not on your list, click Select a language to add.... Select your preferred
language from the drop-down menu and click Add. Your new language is added at the top of your
list. Apps and websites display in the language listed at the top of your list (if the translation is
available).

NOTE
Refresh or reload your already opened tabs containing Control Center to apply your
change.

5. Click OK.

Your Control Center user interface now displays in your preferred language.
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2. On-Premises Installation
If you use NiceLabel Label Management System and you want to install Control Center on-premises,
carefully follow our Control Center 10 On-Premises Installation and Activation Guide.

Whether you need a centralized stand-alone labeling system or large-scale labeling deployments, you can
adapt your Control Center installation work with your existing IT system:

• Simple installation on a single computer

• Installing on a single clean computer.

• Installing on a computer that hosts the SQL Server.

• Advanced installation where your Control Center and its database run on separate machines:

• Installing with database on a stand-alone SQL server.

• Installing with database in a failover cluster.

• Installing with cloud databases.

To share your Applications with Printer Operators, install Web Printing.

IMPORTANT
When you complete your installation, activate your product.
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3. Documents and Workflows
Control Center includes Documents, a centralized storage location for your label templates, applications,
and related files.

In Control Center you can:

• Manage your Documents storage content.

• Manage folder permissions.

• Manage workflows.

3.1. Documents
Documents in Control Center is web-based shared storage for your label files, solutions, graphics, and other
files. Documents works like Google Drive or similar platforms where you can inspect and manage your
folders and files and set permissions for users and groups:

• Manage workflows

• Manage revision control system

• Create label reports

• Compare label files

You can store all types of files in Documents, not just NiceLabel file types.
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1. Folder list (tree view)

2. Search options

3. Main tabs

4. Document properties and preview pane

5. Columns selection

NOTE
Options availability depends on your Control Center edition and user rights set in Access
Roles.

In Documents, you can:

• Search for files and label data.

• Preview your labels, graphics, and PDF files.

• Move files and folders.

• View file properties.

• Upload and download files.

• Open files using WebDAV or HTTP syntax.

• Access the database files in your Document Storage from Web Printing.

• Manage file permissions.

The default Documents view shows three columns: Name, Modified, and Size. To add or remove columns,
click the Columns button, then select or deselect available columns and click Apply.

3.1.1. Managing Files and Folders in Documents

You can manage files and folders in Documents in a similar way as in Google Drive or other web based
file sharing applications. You can use buttons, context menus (by right-clicking on files or folders), and

19



keyboard shortcuts. Context are the most effective way to manage your files. Context menus have dynamic
content, based on the file types and user rights.

In Documents, you can:

• Cut/Copy/Paste files and folders.

• Upload, download, and delete files and folders.

• Preview your label files, images, and PDF files. Label previews allow you to enter variable values.

• Search by different file or folder properties.

• View file history and revisions

• Manage deleted files.

• Manage workflows.

• Compare label files and revisions.

Right-click on items to access options. You can also use keyboard shortcuts.

Tabs, Buttons, and Thumbnails

At the top of the page, there are three main tabs:

• All Files is the default and main page where you manage your files and folders.

• Upload, download, and delete files and folders.

• Preview your label files, images, and PDF files. Label previews allow you to enter variable values.

NOTE
You must be a member of the Administration access role to manage files in Recycle
Bin.

IMPORTANT
When you delete your files or folders from the Recycle Bin, you can't restore them
anymore. Deleting files and folders from Recycle Bin is permanent and includes also
deleting all related revisions and logs.
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Context menus change if you enable additional features like revision control, workflows, and access
permissions.

• Info shows file or folder properties, workflow and revision data, and a small file preview.
If you want to check a bigger preview or a PDF file preview, click the three dots at your selected file,
then click Preview.... In the Preview window you can zoom in or zoom out your label, image, or PDF
file.
Label Preview enables you to test the preview with variable values.
The Preview option is not supported for files other than labels, graphics, and PDFs. But you can
download the files and open them locally.

• Logs thumbnail enables you to check your detailed file and folder events:

• Create

• Rename

• Move

• Check in/Check out/Discard checkout

Logs thumbnail shows the last 5 events. You can check all events if you click See full log.

• Revisions thumbnail shows the last 5 revisions of a selected file and options to download the file,
preview the file and create a Label report. To see all details of the current and previous revisions, click
the Full revision history link. Revision History window opens. You can:

• Create a Label report.

• Revert your files to previous versions.

• Download files.

• Compare revisions.

Buttons:

• New (in the My Files tab).
You can create folders or upload folders and files in the folder that is selected in a tree view.

21

https://help.nicelabel.com/hc/articles/4402326119953?utm_source=Software&amp;utm_medium=F1#comparing-revisions-of-the-same-label-file-1-2
https://help.nicelabel.com/hc/articles/4402326119953-Comparing-label-files#comparing-revisions-of-the-same-label-file-1-2


• Columns (in all three tabs):

Add or remove columns to modify your view.

• Change workflow step (in the Workflow Requests tab):

You can change workflow steps to single or multiple selected files or folders.

• Restore and Delete in Recycle Bin tab:

When you remove your files and folders, they move to Recycle Bin tab where you can restore or
permanently delete them. You must be a member of the Administration access role to manage files in
Recycle Bin.

• Icons in the top right corner to switch between the card and list view of your files and folders.

The default list view and thumbnail view

Icons modifiers

• Cyan dot:
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Workflow is set to folder or file.

• Blue dot with arrow down:

The file is checked out.

• Lock symbol:

You have no permissions on the folder.

• Decommission symbol:

The file is decommissioned.

Using Context menus

By right-clicking your folders you get the additional options to:

• Upload files and folders. (You can also upload your files or folders by dragging and dropping them into
the pane next to the tree view.)

• Cut, copy, and paste files and folders.

• Change folder permissions.

• Create Label Reports.

• Remove files and folders. You can later restore removed folders in the Recycle Bin tab.

By right-clicking your files, you get the options to:

• Rename your files.

• Download files. You can download only one file at a time.

• Copy, cut, and paste your files.

• Remove your files. You can restore removed files in Recycle Bin tab.

NOTE
When pasting files or folders with the same name, files or folders will not be replaced, but
names will get suffixes " (01)", " (02)", etc.

By right-clicking your solution files you get the additional options to:
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• Edit your solution in your NiceLabel Desktop Designer application.

• Run your solution in your NiceLabel Desktop Designer application.

• Create Label reports.

NOTE
NiceLabel V6 form files (.xff) are not supported anymore. Control Center treats V6 form
files as unknown formats. You can still open, edit V6, and run form files in the latest
Designer PowerForms.

By right-clicking your label files, you get the additional options to:

• Edit your labels on your Desktop Designer.

• Print from Desktop. NiceLabel Print application opens where you can print labels.

• Preview your labels.

• Compare your labels.

• Create Label reports.

NOTE
NiceLabel V6 label files (.lbl) are not supported anymore. Control Center treats V6 label files
as unknown formats. You can still open, edit, and print V6 label files in the latest Desktop
Designer.

Context menus change if you enable additional features like revision control, workflows, and access
permissions.

Control Center returns to your last open folder when you close and re-open Documents.

Keyboard shortcuts in Documents

Keyboard shortcuts are mostly the same as in other Windows applications or Google Docs:

Action Press

Select all

(Selects the first 50 items unless you scroll down to display more).

Ctrl+A

Copy Ctrl+C

Paste Ctrl+V

Cut Ctrl+X
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Action Press

Move selection up ↑

Move selection down ↓

Add an upper item to the selection

Remove an upper item from the selection

Shift+↑

Add a lower item to the selection

Remove a lower item from the selection

Shift+↓

Deselect all items Esc

Select a range of items Drag mouse

Delete file or folder Delete

Rename F2

Edit label Enter

3.1.2. Searching for files and label data

Searching in Documents works like searching in your file explorer. You can search the folder that is
currently opened in the main pane. If you want to search the whole Documents, go to the Root folder.

Partial search is enabled by default. For example, when you enter the word lab, your result includes label
and laboratory. To disable partial search, enter your keyword inside quotes, for example, "lab".

NOTE
You can search only files and folders that you can access.

Advanced search for label content includes:

• File name.

• Workflow step.

• Description that you entered when designing labels in Label Properties > Info.

• Printer name.

• Object name that you entered when designing labels in Object Properties > General tab.

• Object content, for example, fixed texts.

• Variable name

• Variable default value (Provisional value in variable properties).

To open the Advanced search window, click the icon right to the Search field.

25



3.1.3. Previewing Label Files

You can preview your label files directly in the Documents without opening your labels in Desktop Designer.

To see your label preview:

1. Right-click your label file and click Preview in the context menu.

NOTE
You can't preview solutions (.nsln files).

2. The preview opens in an embedded window.
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1. By clicking this icon you can edit, print, or download your label file.
2. You can browse for the sample text file containing variable data (name:value pairs).
3. Label preview zoom options with a full-screen button.

NOTE
If you enter the Initial value data in your label variable properties, Variables values
fields shows Initial value content.

NOTE
When you select a double-sided label, the preview shows only the front side. To see both
sides, right-click the label file, then click Print from the context menu. The Preview and Print
window opens with a print preview of both sides of your label.

Control Center can also preview images and PDF files. Right-click the file, and click Preview. You can
preview files with extensions .bmp, .png, .jpeg, .gif, .tif, .wmf, .emf, and .pdf.

If you work with file revisions, you can preview files of any revision from the Revision history for the
selected file.

NOTE
When opening your label preview, you can enter the values for variables and see how they
appear when printed. You can also use database values.
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NOTE
Control Center generates label previews using the installed printer on your Control Center. If
the printer does not exist, Control Center uses a virtual printer instead.

Applying Values From Data Files to Variables

You usually design your label templates with variables that don't have any default value defined. This
ensures that no hard-coded values would be used during printing. On the other hand, it makes the label
preview and comparison more difficult because you have to provide the values for variables before Control
Center generates the label preview. When generating the label preview, you can enter values manually.

You can also provide Control Center with the external data file (a list of variables and their values). Control
Center applies the data file for the generating label previews. The data file must provide the name:value
pairs. If the variable of the same name is not defined in the label, the name:value pair is discarded.

NOTE
You can let Control Center find the data file based on the rules defined below, or you can
click the folder icon next to the label name/preview and override the defaults with your data
file.

Data file structure

You can create your variable data file in XML or delimited structure.

XML structure

You provide your variables within <Variables /> root element in your XML file. Provided variable names
with attribute names and variable values with the element value.

<?xml version="1.0" encoding="utf-8"?>

    <Variables>

    <variable name="customer">Pizzeria Manhattan</variable>

    <variable name="country">Belgium</variable>

    <variable name="Lot_nr">478887566</variable>

</Variables>

Delimited structure

Create every name:value pair in a newline. Variable name is to the left of the equals character (=), variable
value is to the right.

customer=Pizzeria Manhattan

country=Belgium

Lot_nr=478887566

Data file naming convention
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The name of the data file can be the same as the name of the label, but using the extension .values. This
private data file allows you to provide different data file for each label.

If you have a label named label.nlbl, name your data file label.values.

The other option is to use the same generic data file for all labels. In this case, name the data file
default.values. The name:value pairs within will be used for all labels.

NOTE
If both files exist in the same folder, the file label.values will take precedence over the
file default.values.

Data file location

You can store your data file in any location in the Documents storage.

Example

You stored your label pasta.nlbl in the folder /food labels. The path to your label is /food
labels/pasta.nlbl.

Control Center searches for your data file in the following order.

1. The private data file in same folder as the label file.

Example

/food labels/pasta.values

2. The private data file in the subfolder SampleValues.

Example

/food labelsfolder1/SampleValues/pasta.values

3. The generic data file in the same folder as the label file.

Example

/food labels/default.values

4. The generic data file in the subfolder SampleValues.

Example

/food labels/SampleValues/default.values
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When Control Center finds first available .values file, the search stops and the contents of the data file is
used for the label preview.

NOTE
Using the SampleValues subfolder is useful when you have a workflow process defined
in the label folder, but you do not want the same workflow to govern your data files. In
this case, you can store the new version of the data file without going through all workflow
steps.

3.1.4. Direct File Access

You can access your files stored in Documents directly from your browser. Here is the syntax:

WebDAV syntax:

\\<server>@8080\DavWWWRoot\folder\label.nlbl

Secure connection to Documents:

\\<server>@SSL@8080\DavWWWRoot\folder\label.nlbl

HTTP syntax:

http://server:8080/folder/label.nlbl

Secure connection to Documents:

https://server:8080/folder/label.nlbl

3.1.5. Custom Fonts

If you use custom fonts for labeling, you can upload and store your fonts in Control Center Documents.

The dedicated font storage location in Documents is /System/Fonts. Control Center uses fonts from /
System/Fonts for label previews.

To upload your custom fonts to Documents:

1. Go to Documents > System > Fonts folder. If the System folder doesn't exist yet, create one at the
root level and create a Fonts subfolder.
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2. Upload your folders to the System/Fonts folder.

NOTE
You can't use custom fonts with the Text on ellipse effect. Read the Desktop Designer User
Guide for more details.

NOTE
To use custom fonts in the Rich Text Box object, make sure you enable the Alternate
rendering option. Read the Desktop Designer User Guide for more details.

3.2. Folder Permissions
Manage your folder permissions when you want to limit access to certain folders in Documents to specific
groups of users. You can customize access permissions for folders and subfolders by specific access roles
and apply them to all access role members.

NOTE
For the on-premise Control Center, you must enable Authentication first.

If you don't enable authentication, Control Center applies the default permissions. All users
have full permissions on all folders stored in Documents.

3.2.1. Folder permissions rules

These rules define folder permissions in Documents:

• You set folder permissions for folders together with access roles. Users can be members of multiple
roles that affect reading, writing, editing, and deleting permissions in Documents storage.

• All permissions you set for a folder apply both to folder contents and to subfolders.

• Subfolders inherit permissions from parent folders, but you can set custom permissions for each
subfolder.
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3.2.2. Additional Workflow-related folder permissions rules

When you apply specific workflow processes to your folders, these additional rules apply:

• If you have read-only access to a folder, you can only read the last approved-published revision of your
files. If files are not yet approved-published, you can't read them.

NOTE
Users in production environments must have read-only access to ensure they see only
approved-published revisions.

• When you have full folder access (read and write permissions), you can read all file revisions.

3.2.3. Changing folder permissions

NOTE
You can manage folder permissions if you log on to Control Center as Administrator.

Folder permissions depend on Access Roles.

You can set folder permissions by editing Access Roles.

1. Go to the Users tab > Access Roles and click a role to customize from the list.

NOTE
If you want to add a new role, click Add and then follow the steps below.

For more information about adding Access Roles see a dedicated topic.

2. Go to Permissions for this role window > Documents tab to set general and default permissions for
all folders.

3. To set custom permissions for specific folders or subfolders, scroll down to Custom Document
Permissions.

4. Select a folder and click Customize.
Control Center opens the Customize permissions dialogue for the folder you select.

5. Click specific storage and workflow permissions to apply to this role and folder.

NOTE
Access role settings you change for this folder apply to all users assigned with this
access role.
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6. Click Customize.
Permissions you set for this role and folder now display in the Custom permissions dialog of
Custom document permissions.

7. Click Save to save your settings and continue working.

Custom folder permissions you set are saved and now apply to all access role members.

3.2.4. Specific access permission options

NOTE
For On-premise Control Center you need the Enterprise license and Authentication enabled.

Decommissioning Files

If a published label or solution file becomes obsolete during its life cycle, decommissioning allows you
to make the file unavailable for read-only users. Decommissioning makes deleting obsolete files from
the Documents storage unnecessary. The Decommissioning Files option just hides the obsolete files and
makes it available again using recommissioning.

Decommissioning/Recomisioning is only available if you enable Workflows and Versioning.

To decommission your file in the Documents storage:

1. Right-click the file to display the context menu and click Decommission. The confirmation window
pops up.
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2. Click OK to continue. The confirmation window opens. Type in the reason why you are
decommissioning the file.

After you have decommissioned the file, the file icon gets updated: . This icon indicates that the
file is no longer visible to the read-only users.

NOTE
You can decommission files even if they are not currently published. This option
is available also for files that are still in the approval process or have been
unpublished in the past.

Recommissioning files:

To make the decommissioned files visible again, use recommission option:

1. Right-click the document to display the context menu and click Recommission.
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2. The confirmation window opens. Type in the reason why you are recommissioning the file. The file
is again visible to the members of access roles with read-only privileges.

NOTE
You can view the decommissioning/recommissioning events and their details in Control
Center History.

By default, members of Administrator and Approver access roles have permission to decommission files.
To allow other access roles to perform decommissioning:

1. Go to Administration > Access Roles.

2. Select the access role.

3. In Permissions for this Role go to the Documents tab.

4. In Default document permissions > Workflows enable or disable Decommission / Recommission
files.

3.2.5. Removing published files

By default, only members of the Administrator role access role can remove published files from Documents
storage. Administrators can also allow removing the published files to any other access role.

To grant the selected access role the right to remove published files from Documents storage:

1. Go to Administration > Access Roles.

2. Select the access role.

3. In Permissions for this Role > select Documents tab.
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4. Under General Document Permissions (all folders) enable Delete published files .

5. Click Save (on the top or bottom of the page) to save your settings and continue working.

NOTE
You can delete folders that contain published files. If you do not have permission to delete
the included files, an error dialog with a list of files that cannot be deleted pops up.

3.3. Label Reports
You can use the Label Report feature to create a detailed description of the structures and previews of your
label templates.

In the Label Report, you can see detailed information about your selected label templates. You can
generate label reports on the single label template, group of label templates, all your label templates in
the selected folder, or on the specific revision of the label files.

Label Report contains:

• Meta-data (name, author, description, printer data)

• Workflow step log (date, user, data, comment)

• Structural information (list of label objects and variables with their contents)

• Label preview

NOTE
Variable values show on label preview only if you provide Initial value data on your
label design. If there is no initial value, question mark signs show on the label preview.
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You can use Label Report information to build a label catalog (a list of all labels you use in your
environment). This helps you to keep track of the number of label templates, their structures, and their
intended usage. Before creating a new label template, you can verify your label catalog if a similar label
already exists. You can use the existing label template as a master template for your new label.

You can download your label structures in JSON or XML format.

3.3.1. Generating Label Report

You can get your label report:

• On your selected label file(s). You can select one or more label files by right-clicking on them and
select Label Report. Label report opens.
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• In your folder. Select your folder, then right-click it and select Label Report. Label report will be
generated for all label files in this folder and subfolders.

• For a specific revision of your label file. Select your label file and go to the Revisions tab. Click the
Full revision history.

The Revision history window opens. Select your revision(s), then click the Label Report button.
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NOTE
Control Center generates label previews using the installed printer on your Control Center
server. If the printer does not exist, Control Center uses a virtual printer instead.

NOTE
If a stored label has Prevent font replacement option enabled, label preview becomes
unavailable in case of missing fonts. See Desktop Designer User Guide for details.

3.4. Comparing label files

Compare feature provides previews and a graphical comparison of different label files or different revisions
of the same label file.

The color coding allows you to spot all differences.

NOTE
Graphic comparison is available for the label (.NLBL) files and graphics.

3.4.1. Comparing Different Label Files

To compare different label files, do the following:

1. Open Documents in Control Center and navigate to the folder with labels you want to compare.

2. Select two or more labels in the same folder.

3. Right-click in the file selection pane and select Compare.
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4. Select two label files for comparison. The superimposed image of label differences shows the
previews of the two selected labels. Changes in label designs display in color.

By default, dark magenta belongs to the left preview and bright magenta belongs to the right
preview. To switch both magenta colors, press the middle icon with two arrows.

To disable/enable left or right preview in the Comparison window, click the eye icons.
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3.4.2. Comparing Revisions of the Same Label File

To compare revisions of the same label file:

1. Right-click the label that has at least two revisions and select Compare.

2. Select two revisions for comparison. The superimposed image of label differences shows below
the preview of the two selected labels. Changes in label designs display in color.
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Applying Values From Data Files to Variables

You usually design your label templates with variables that don't have any default value defined. This
ensures that no hard-coded values would be used during printing. On the other hand, it makes the label
preview and comparison more difficult because you have to provide the values for variables before Control
Center generates the label preview. When generating the label preview, you can enter values manually.

You can also provide Control Center with the external data file (a list of variables and their values). Control
Center applies the data file for the generating label previews. The data file must provide the name:value
pairs. If the variable of the same name is not defined in the label, the name:value pair is discarded.

NOTE
You can let Control Center find the data file based on the rules defined below, or you can
click the folder icon next to the label name/preview and override the defaults with your data
file.

Data file structure

You can create your variable data file in XML or delimited structure.

XML structure

You provide your variables within <Variables /> root element in your XML file. Provided variable names
with attribute names and variable values with the element value.

<?xml version="1.0" encoding="utf-8"?>

    <Variables>

    <variable name="customer">Pizzeria Manhattan</variable>

    <variable name="country">Belgium</variable>

    <variable name="Lot_nr">478887566</variable>

</Variables>

Delimited structure

Create every name:value pair in a newline. Variable name is to the left of the equals character (=), variable
value is to the right.

customer=Pizzeria Manhattan

country=Belgium

Lot_nr=478887566

Data file naming convention

The name of the data file can be the same as the name of the label, but using the extension .values. This
private data file allows you to provide different data file for each label.

If you have a label named label.nlbl, name your data file label.values.
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The other option is to use the same generic data file for all labels. In this case, name the data file
default.values. The name:value pairs within will be used for all labels.

NOTE
If both files exist in the same folder, the file label.values will take precedence over the
file default.values.

Data file location

You can store your data file in any location in the Documents storage.

Example

You stored your label pasta.nlbl in the folder /food labels. The path to your label is /food
labels/pasta.nlbl.

Control Center searches for your data file in the following order.

1. The private data file in same folder as the label file.

Example

/food labels/pasta.values

2. The private data file in the subfolder SampleValues.

Example

/food labelsfolder1/SampleValues/pasta.values

3. The generic data file in the same folder as the label file.

Example

/food labels/default.values

4. The generic data file in the subfolder SampleValues.

Example

/food labels/SampleValues/default.values

When Control Center finds first available .values file, the search stops and the contents of the data file is
used for the label preview.
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NOTE
Using the SampleValues subfolder is useful when you have a workflow process defined
in the label folder, but you do not want the same workflow to govern your data files. In
this case, you can store the new version of the data file without going through all workflow
steps.

3.5. Versioning (Revision Control System)

Documents includes a Revision Control System for versioning your labels, images, and other related files.
Your Revision Control System stores a history log of your files and allows you to:

• Edit all revisions (versions) of your files.

• Track changes made to your files.

• Revert to the previous revisions.

When you edit a label file from Documents in Desktop Designer and then save it, Control Center generates a
new file revision (version). Control Center keeps all previous file revisions so you can revert your label files
to older versions.

NOTE
To keep all file versions available, enable Versioning for your Control Center first. Go to the
Administration tab > Versioning and Workflows > Document Storage Settings section.

You can also create a new file with the same name and upload it to Documents. In this case, enable
Overwrite existing files checkbox. Revision number increases in this case.
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NOTE
By default, label files in Documents are locked for editing. You can open your label files
in read-only mode. To edit your label files, you must check them out in Documents. or in
Desktop Designer.

3.5.1. Working with Revisions

The revision control system ensures transparency when reviewing your labels, solutions, or other labeling
assets in the Documents. After each document check-in, your Control Center stores information about
workflow promotions, check-ins, changes, and user comments. Control Center also keeps track of who and
when performed all the actions.

When checking in your files, you can choose between minor and major file versions.

• Minor revisions mark smaller user edits when you work on drafts apply smaller corrections.
If you check out your document, then edit your document, then check the document in without
promoting it to the next workflow step, Control Center creates a new minor version by default.

• Major revisions mark significant changes in your documents made before a label or solution
designer assigns files to the approvers. Typically, new major revisions correspond with workflow
step promotions.
The administrator can choose which workflow step marks a change in your documents as a new
major revision.
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3.5.2. Checking out files or folders

Before you can start editing your files in Documents. you have to check them out. The checked-out files are
marked and locked for editing for any other user. All other users can see the current revision of the files.
You can check out files in Designer or in Control Center.

To allow other users to make changes to the files, you have to check in files or discard check out status.
The methods are available in the Designer and Control Center user interface.

To check out your files or folders in Control Center, right-click your selected files or folder, then select Check
Out in the context menu.

To check out your files or folders in Designer, click the Check Out icon in Document Storage tab.

WARNING
If you click Discard Checkout, you irreversibly lose all changes that any of the users did
after checking out files. To keep the changes, check in your files or folders.

In the Info panel you can see who checked out the file, so you can ask them to save their
work before you discard check out.

3.5.3. Checking in files or folders

When you are finished editing your files and want to make them available to other users, you must check in
your files or folders. You can check in files in Desktop Designer and Control Center.

To check in your files or folders in Control Center, right-click your selected files or folder, then select Check
In in the context menu.

To check in your files or folders in Desktop Designer, click Check In icon in the Document Storage tab.

WARNING
If your solutions use dynamic values (Remember the last used value option), the dynamic
variables file (.dvv) must be checked out. If .dvv file is checked in, an error will occur when
printing, and labels will not print.

Instead of using dynamic values, use global variables or Save Variable Data / Load Variable
Data actions in your solutions.

When you check in your file, the file revision increments, and your entered comment is logged.
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3.5.4. File Revision history

Every change to your files are logged in Control Center database. The file revision history includes all events
occurring for files, including revisions and workflow changes.

To see all activities for the file, do the following.

1. Right-click your file, then click Revision History in the context menu.

You can also select your file, then go to the Revisions tab and click Full revision history.

2. The Revision history window with all details opens.
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1. Major revision number.
2. Minor revision number.
3. Create label report. A label structure report opens in a new browser tab Label report includes
meta information about your label including the graphical preview, and a list of all label objects and
variables. You can also download label report as XML file.
4. Download the label file. You can download local copies of all existing label revisions from
Documents to your computer. Open your downloaded copies in Desktop Designer and use them to
create new revisions.
5. Compare all revisions. You can graphically compare the changes from one document revision to
another.
6. Revert the current revision to the selected revision. You can revert files to any of their previous
revisions. This action copies the selected file revision and adds it as the latest (current) revision.

NOTE
Reverting to label revision is reserved for access roles with Read/Write permissions
for the current folder. See how to set access permissions for folders in the section
Managing folder permissions.

You can also preview any revision of your label file. Use this feature to avoid opening labels in
Desktop Designer.

3.5.5. Requesting Label Revisions

In some cases, you might want to use some older label revisions in your Automation or PowerForms
solutions.
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NOTE
You can open and edit files depending on your Access Role. Access Roles are based on
user permissions.

Requesting HEAD Revision (Latest Available)

If you request a file without specifying any revision, the latest available revision will be used in your printing
solution.

• If you have read/write access to the files, you can open the files with the last revision.

• If you have read-only access to the file, you get:

• The last revision (if the folder doesn’t have any workflow enabled).

• The last approved-published revision (if the folder is assigned to the workflow process).

Requesting Specific Revision

To request a specific revision in your printing solution, provide the revision as a parameter after the file
name. For example, to request revision 10 of the file pasta.nlbl, use the syntax:

pasta.nlbl?v=10

WARNING
Users without permission to use older revisions will get an error message when running
solutions with older revisions.

Requesting the Last Published Revision

To request a specific revision, provide it as a parameter after the file name.

To request the last published revision of file pasta.nlbl, use the syntax:

pasta.nlbl?v=P
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If no file revision is approved, your solution will show the error message.

3.6. Workflows

Control Center allows you to enable workflows along with Section 3.5, “Versioning (Revision Control
System)”. Workflows let you set additional quality controls in your label printing process. Workflows include
sequences of connected steps that follow workflow logic. Every workflow has at least a starting step and a
final step. There might be one or more possible promotion steps from the current step.

IMPORTANT
You must enable authentication in Control Center to use workflows.

Using workflows, you can track the status of your label files.

When you include folders in your workflow process, the revisions users see when they request label files
depend on their access role privileges. For more information, read Managing folder permissions.

3.6.1. Approval Process

IMPORTANT
Enable authentication in Control Center to use the approval process.

Approval steps depend on the type of workflows you use. Control Center sets the hierarchy of workflow
steps for each default workflow and which steps are permitted next.

Files you upload to Document Storage in workflow-enabled folders start on the Draft step. When authors
complete their initial layout and label contents, they move the file to the next step: Request approval. When
configured, approvers receive email notifications for files they're assigned to review and approve. Approvers
can Reject files (this notifies Authors to make changes) or approve them. Approval moves the files to the
Approved step. Each workflow defines available steps and the transitions from one step to another.

NOTE
To successfully send notification emails, your email server must be whitelisted.

If your email server is not whitelisted, the following error occurs:

Value cannot be null. (Parameter 'address')
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Moving files to the Approved step can require users to provide login credentials again. Re-authenticating
this way confirms the correct users are still logged in. The Two-step label production approval process
includes this re-authentication by default.

The Approved step (or Published step in some workflows) is the final state for files. You cannot use labels
in production until they are approved and published. Operator role members (or any users with print-only
permissions) can only see files on the Approved/Published step. Authors can work on new revisions of
label files, but these changes are not visible to print-only users until their revisions reach the Approved
state.

NOTE
Files only become visible to Operator access role members (print operators and print-only
users) when they are approved/published.

3.6.2. Label Production Approval Process

This workflow uses standard approval processes. Documents start as drafts. When ready, the authors
request approval. Approvers either approve the documents or reject them. If rejected, authors can make
additional changes and request approval again. When approved, documents are published automatically.

Operators can only see published documents. Operators have print-only permissions and can only use
the latest approved (and published) documents. If unapproved revisions exist in Document Storage, they
remain invisible to print operators.

The system documents each workflow step change. When users change steps, they must enter mandatory
comments.
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3.6.3. Two-Step Label Production Approval Process

This workflow is similar to the Label production approval process workflow with a single difference. This
workflow enables the two-level approval process. Before the document is approved (and published), two
independent approvers must review and approve the document. Only after the document has surpassed
both approving steps, it becomes published.

NOTE
Independent approvers must be logged in Control Center as unique users.

This process can be configured to have two separate approvers (or two groups of multiple approvers)
defined for each step of the approval process.

• Request first approval: assigns unique users for the "step one" approval.

• Request final approval: assigns unique users for the "step two" approval.

To reach the approved status, the document must be approved by a unique member of both groups.
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3.6.4. Label Production Approval Process with Delayed Publishing

This workflow is similar to the Label production approval process workflow with one difference. This
workflow differentiates between the Approved and Published states. When the document is approved, it
is functionally complete, but not automatically used by the print operators yet. In some environments, the
move into the final Published state must be performed with a delay. The document might have to wait until
the next work shift, or until a specific date, such as after the public holidays, or when a production order
requires new label designs. You can schedule the future date and time for the publishing to occur.

The transition to the Published state can be done manually, or automatically by the system. The state
Approved is not a final state, but is followed by:

• Published. In this case, the transition into the Published state is completed by the user.

• Scheduled for publishing. In this case, the transition into the Published state is completed by the
system on a date and time as defined in the workflow.

In both cases, the change of the step is logged into the system database.

53



3.6.5. Enabling Workflows

You enable your workflows if you go to the Administration tab > Versioning and Workflows. Set Workflows
for document storage to Enabled.

1. Go to the Documents tab.

2. Right-click the folder where you would like to enable workflow control, then click Set Workflow
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3. Select the option you want to enable for the folder.

• No workflow disables workflow control for the current folder.

• Inherit workflow from parent folder. When you change the workflow on the parent folder, the
change applies also to your current folder.

• Select workflow defines the workflow for the current folder. You can select the built-in
workflows or use your custom-created workflow.

3.6.6. Assigning Workflow Steps to Files or Folders

All files in the workflow-controlled folders are assigned to one of the workflow steps.

When you upload new files or enable a workflow for the existing folder, your files are in the initial step of
the workflow. In the case of built-in workflows, such as Label production workflow and Two step approval,
the initial step is Draft. When you change the workflow step for the selected files or folder, the new step
is automatically assigned to the documents, for example, Request approval. You can only change the
workflow step to the next step(s) as defined by the workflow rules.

You can change the workflow step if you right-click selected files to open the context menu., then click
Change Workflow Step.

Changing workflow step to the next available step. In this case from Draft to Request approval.

Control Center allows you to simultaneously change the workflow step for multiple files or folders. Select
your files or folders and right-click to open the context menu. Select the Change Workflow Step option to
promote your files to the next available workflow step.
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Changing workflow step to multiple files with selected preview.

There are two conditions to promote multiple files or folders to the next workflow step:

• All selected files or folders must be on the same workflow step.

• None of the files or folders must be checked out.

When your files or folders are assigned to the Approved step, print-only users can access it. Print-only users
are usually members of the built-in access role Operator, but you can also create your own roles.

Print-only users can be also allowed to print files in other workflow steps (in case of solution developing
and testing). Go to User Management to change or add roles to users.

3.6.7. Configuring Delayed Publishing

To enable delayed publishing of approved files and schedule file publishing:

1. Assign your folder to Label production approval process with delayed publishing workflow.
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2. Process your files through the workflow process until you reach the Approved step.

NOTE
In this process, the Approved step is not the final step. To enable your files to print,
files must reach the Published step.

3. Right click your selected files and click Change Workflow Step.

4. In the Next step drop-down menu select Scheduled for publishing.

5. Choose Automatic transition time when your document should be published.
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6. Enter the comment and click Change workflow step.

Control Center monitors all scheduled actions, and performs the workflow step changes automatically at
the defined time.

3.6.8. Limiting Folder Access for Approvers

You may want to update Approver privileges when:

• You only want one approver to be able to work with documents in a folder. If you are a member of the
Approver Access role grants access to all folders by default.

• The approver can work with files in Folder1, but not with files in Folder2.

The solution is to disable file access to the Approver Access role and then allow access case-by-case by
adding users to other roles.

To change the workflow step from Request approval to Approved, Rejected, or any other defined step:

• The user must be a member of the Approver access role.

• The Approver access role must have read/write permissions for the Documents storage folder
that contains the documents in the Approval step. For details, read the section Managing folder
permissions.

58



NOTE
If you want to approve or reject documents and you are not the Approver, you can also
approve or reject the documents, but you should be a member of the Administrator role.

To limit the ApproverAccess role from your folder:

1. Log in to Control Center as the administrator.

2. Go to the Users tab > Access Roles.

3. Click Add. The Create new access role window opens.

4. Type in a name of a new role, for example, Selective access, then scroll down to Users in this role
and add users. Click Save.

5. Expand the Approver role and make sure the users from Selective access role are also a member of
the Approver role.

6. Change Folder permissions to folders where you want to limit folder access.

7. Update the Approver role, by disabling all permissions, then edit the Selective access role by
enabling Workflows permissions.

Only Selective access role members can approve files in your folder now. Approver role members have no
access to this folder.

3.6.9. Changing Workflow Steps Transitions Permissions

You can add or remove Access Roles that can make transitions between workflow steps.

To change the permissions:

1. Go to the Administration tab > Versioning and Workflows.

2. In the Workflows section click the workflow where you want to change the permissions.

3. The Steps window opens. Double-click the arrow (transition) where you want to change the
permissions.

4. Add or remove Access roles.
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5. Click Save.

Your Workflow steps transitions permissions are now changed.

3.6.10. Creating Custom Workflows

Control Center allows you to create new custom workflows. Use custom workflows to match the specifics
of the labeling process in your company.

Before you decide to create and use custom workflows, analyze your labeling process and the built-in
Control Center workflows first. Consider these three available options:

• Introduce an entirely new workflow. In this case you are creating a new workflow from scratch.
Although this is the most flexible option, make sure you know your approval process well enough
before you start building a workflow. This saves your time and helps you eliminate potential future
errors.

• Edit the built-in workflows. In this case, we recommend you to duplicate and customize the most
appropriate built-in workflow. Because the steps in a duplicated workflow are already configured, you
must only make the necessary changes to adapt the workflow steps to your label approval process.

• Try to redesign and match your labeling process with the built-in workflows. This option makes sure
your selected workflows are fully tested and functional from start.

Before you start creating or editing the workflows, get familiar with the terms used in your workflow editor:

• Steps: Each workflow contains one or more phases called steps. During the approval process, your
documents go through the predefined approval steps. You can create, name, and order your steps,
then assign states to each step.

• States: States determine what you can do with a document during a workflow step. States include
Working, Locked, and Published (see below for a detailed description of states). Users assigned to
custom workflow steps can only use the states you assign to your steps.

• Transitions: You control the workflow’s direction with transitions. For example, when a reviewer
rejects someone’s changes, you can direct that document back to the submitter, or forward it to a
different reviewer. All steps can transition forward or backward, except your initial step.

• Delayed publishing: Workflows can contain timed approvals that automatically transition your
documents form Approved step to Published at the time you choose.

• Who to notify in this step: You control who gets email notifications for each workflow step.

• Enabled workflows: You can toggle workflows on and off. All workflows require Versioning to be
enabled.

NOTE
To create customized workflows, you must be a member of the Administration Access
Role.
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To create a new workflow:

1. Go to Administration > Versioning and Workflows.

2. If you want to add a new custom workflow, click Add. The editing window for a new workflow
opens.
If you are adding a custom workflow based on one of the existing workflows, select the existing
workflow and click Duplicate. The editing window for a duplicated workflow opens. Further
configuration steps are the same as for a new workflow except for the already configured steps.

3.
NOTE
This step is available only in On-premise Control Center.

4. Add and configure your workflow steps. Click Add step in the Steps field to add new steps. To edit
an existing workflow step, click the step and click Edit.

• Type the Step name.

• Select the File state changes to for this step:

• In progress (working): Reviewers can check in, check out, and change the document.
Use this state for earlier approval steps when you expect multiple changes to the
document, such as draft, first level approval, etc.

• In approval (locked): The document is read-only in this state. Reviewers can only review
the document. Use this state to keep documents unchanged on the current step. For
example, when requesting approval.

• Published (locked): All members of all access roles can see the documents. Use this
state when documents are ready to use in production.

• Set your first workflow step as the Initial step. You can only define one step as the initial step.

• Login required (Electronic signature) is an additional security measure that prevents
unauthorized users from making changes to workflow steps.
After you enable the Electronic signature, users authorized to promote the documents to the
next workflow step must authenticate again with Control Center credentials.
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NOTE
While authenticating with the Electronic signature, your session remains
open. After the successful authentication, you can continue promoting your
document.

• Allow setting major revision: If your document had a minor version in the preceding workflow
step, the promotion changes the current (minor) revision number into a major revision.
This option is not available if you enable the option Use only major revision numbers. Check
its status in Administration > Versioning and Workflows. Read more in section Versioning and
Workflows.

Example

Document's revision number in the "Draft" step was 3.2. After promoting the document to the
"Request for approval" step, its revision number goes to 4.0.

• Notification emails. When a documents reach the workflow steps, the listed users receive
emails with the links to the documents.

NOTE
If you change the workflow step for multiple documents at once, the listed
recipients receive separate emails for each document.

• For each workflow step, you can define which users receive notification emails after a
document reaches the current step using Allow the person who makes a transition to choose
the recipients option.

Repeat the configuration for all of your planned workflow steps. The new steps are listed under the
Steps of your new workflow. Click Create in the top-right corner when you are done.
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5. To send notification emails to the users who should be informed about the changes in workflows,
click SMTP Settings.

6. After defining the steps for your workflow, define how will you promote the documents to the
next workflow step. The transition allows you to define the promoting options for your documents:
approvals, rejections, and time delays before publishing. Click Add transition to define the transition
to the next step in your workflow. The Add Workflow Step Transition window opens. Define your
order of the steps, who can make transitions, delayed publishing, and multiple approvals.

7. After you define your custom workflow, you can apply this workflow in your Documents the same
way you apply the built-in workflows. See section Enabling Workflows for details.

8. If you want to delete your workflow, make sure that none of the files in your Documents use the
workflow or any of its steps.
If an error or warning occurs while deleting your workflow, try deleting the individual steps first.
When deleting the workflow step that is in use, a warning displays the names of the files that use
the workflow step you are trying to delete.

NOTE
You can't delete the built-in workflows.

63



4. Applications
Applications are a fast and safe way to share your label templates and Solutions with internal or external
users - printer operators. Applications give you the flexibility to share your labeling files with multiple users
in multiple locations while maintaining control of how your labels are printed. With Applications, you can
quickly scale and adapt your labeling process to your needs.

Sharing your label templates or Solutions with Applications ensures:

• Your users always get the latest versions of approved labels templates and Solutions.

• You can enforce user login policy.

• You keep track of your label printing history.

• You can manage your used printer licenses by setting usage limits for your Application printers and
users.

Learn how to:

• Create and share your new Applications.

• Configure your Applications for specific users or groups.

• Restrict application logins and printers.

• Record printing actions.

• Use file database connections in your Applications.

• Access and use your shared Applications.

4.1. Creating and Sharing Applications
With Applications, you share your label and Solution files stored in your Control Center Documents with
your internal users or external users (for example, print operators).

IMPORTANT
For Label Management System on-premises, make sure you install NiceLabel Web Printing
on your server before you share your Applications.Web Printing is a web application that
allows you to centrally deploy your Applications to your print operators.
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4.1.1. Creating New Applications

To create your new Application and configure general Settings:

1. Go to the Control Center Applications tab, and click Add.

2. Enter a Name for your Application. Give your new shared Application a meaningful name to make it
easier to identify later.

3. Enter your Description. Explain the purpose of your Application.

4. Select your Application type. You can choose to open:

• Single solution or label file

• Folder with one or more solution or label files
With this option selected, you don't need to create separate Applications for each file in your
folder. You can add or remove label templates from your folder.

WARNING
Applications don't work with dynamic values (Remember the last used value
option). Use workarounds instead, for example, write and read variable values to
your database.

5. Under Path, click Browse and navigate to your label template, Solution, or folder stored in your
Control Center Documents.
You can also type the file path directly. Begin your relative file path with a slash: (/).
/Labels/Test_label.nlbl

If your label or solution file uses a file database connection (with Microsoft Excel or Access
database), read Using File Database Connections in Applications to ensure the accessibility of your
data.

Your next step is to define the Application's Authorised Users and Groups.

4.1.2. Defining Application's Authorised Users and Groups

Define your authorized users and groups to restrict access to your shared Applications and make your
labeling environment more secure.
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TIP
You can skip this part and add your users later.

Defining LMS Authorised Users and Groups

Define your Authorized Users and Groups:

1. In Applications > Applications click Add. Create New Web Applications page opens.

2. In the Authorized Users and Groups section click Add. The Add Users to your Authorized List for
the New Application dialog opens.

Share your Application with existing users or groups. Use the Search users field to type your
selection.
If your company uses the active directory, you can either select specific Windows users or Windows
groups. To open your shared Application, all added users must authenticate themselves using
Windows authentication.

3. Click Create New Application User to add your new Control Center user. Enter the Username and
set the Password. Click OK. You can now share your application with the new application user.

Your added users or groups are now listed among the Authorized Users and Groups and can start using
your shared Application.

NOTE
Notify your Application Users manually about the new shared Application.

To restrict access to your shared Applications, you can later remove your added users or groups from the
Authorized Users and Groups. Select them from the list and click Remove.
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Defining Authorised Users and Groups for multiple users

In certain cases, you want to assign your Application to a list of Windows users. To speed up the process of
adding multiple users, list these users in a table and manually add them to your shared Application:

1. In Applications > Applications click Add. Create New Web Applications page opens.

2. In the Authorized Users and Groups section click Add. The Add Users to your Authorized List for
the New Application dialog opens.

3. Click the Add Users or Groups Manually link. A dialog opens.

4. Under Type, select if you want add Windows users or groups. .

5. Paste or enter your users, each in a separate line.

6. Click OK.

7. Click Add.

Your added users or groups are now listed among the Authorized Users and Groups and can start using
your shared Application.

To restrict access to your shared Applications, you can later remove your added users or groups from the
Authorized Users and Groups. Select them from the list and click Remove.

4.1.3. Configuring Application's User Settings

Configure your user settings to:
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• Customize and track your printing activities.

• Limit who can access your Applications and how many printers (printer licenses) they can use.

Configure User Settings:

1. In Applications > Applications click Add. Create New Web Applications page opens.

2. Navigate to the User Settings section.

3. Under Status toggle between Active or Suspended.
Your applications are Active by default. This means that your users can start working with them
immediately. If you want to prevent the usage of your Application, set the status to Suspended. This
is useful during your testing phase or if you wish to postpone the use of your Application.

4. Under Record printing activities to the history log toggle between On and Off.
Record printing activities to history log keeps track of user printing actions within your shared
Application. This option allows you to start or stop the recording of printing activities in Control
Center.
See the recorded activities on the Control Center History page.

NOTE
Recorded information items are: label name, label quantity, printer name, variable
values, etc.

5. Restrict your Application logins and printer usage:
Web Printing gives you Application access control and allows you to limit the number of used
printers for your shared Application.

a. Allowed IP addresses enables you to give access to your Application's login only to computers
with certain IP addresses. Your shared Application blocks computers with non-defined IP
addresses. Enter each address in a separate row, or separate them with a semicolon (;). To
specify your address range, use CIDR notation. You can convert subnet mask notation into
CIDR notation using online calculators.

Defining a range of permitted IP addresses

To allow login from any IP in range 192.168.0.1–192.168.0.254, define the range as
192.168.0.0/24.
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b. To Enable printer limitation toggle between On or Off. When On, define the Number of printers
your Application users are allowed to print on.

WARNING
Each printer used in your shared Application takes one printer license. This
setting makes sure you don't accidentally run out of available printer licenses
that come with your NiceLabel license.

Number of printers is the maximum number of allowed printers per user for your Web
Application. If users exceed this number, they can no longer print to additional printers.

6. Under Variable values, you predefine values for custom variables for your shared label or solution
file.
Variable values are commonly used for pre-defining Application (Solution) languages or settings, or
label template active layers.

Language as a variable

For example, users from two different regions use the same Application simultaneously. Users from
the first location need the Application in the French language, while users from the second location
need their version in the German language.

While each region must have the Application in its own language, all users need to experience the
same look and feel of the Application.

In this case, you define the same Application for users in both locations and define the starting
value of your language variable. Use this variable as a filter in your database table, displaying strings
in the right language. Usually, the criteria are simple relations, such as field_name = variable_value.

To set variable language to starting value French, use the following syntax: "language" = "French"

NOTE
Check for typing errors in variable names and values. Also, make sure to test your
Application before you allow your user to log in. Your Application doesn't display an
error if you assign values to non-existing variables.

If your variable name includes space, use double-quotes ("") to define your variable.

7. Enable use of non-published files in Document Storage allows you to permit your Application
users to work with versions of label templates and Solutions that are not published (approved).
By default, Applications only share label templates and Solutions that complete all your workflow
steps and are marked as approved. Sharing non-published files can be useful as part of various
testing scenarios.

8. Click Save.
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NOTE
If you use LMS product, after you save changes on the Applications page, send a
notification email to your users or groups manually.

Your new Application is now accessible in Control Center, under the Applications page, and ready for
sharing.

4.1.4. Updating and Removing Applications

You can always go back and reconfigure your Applications:

1. Go to Applications and click on the Application you want to update.

2. Change your settings and configure your Application according to your needs.
If you want to replace your label or Solution file, change the Path under Settings.

3. Click Save.

To remove your Applications, select them from the Applications list and click Delete. Deleting your
Applications won't delete your label or Solution files connected to your Application.

4.2. Configuring Applications for Specific Users and
Groups
You can configure your Application settings per single user or group. These settings are valid only for the
specific user/group that you define and have no impact on the general configuration of your Application.

With User Settings, you can limit the maximum number of allowed printers to print to and define variable
values. Limiting printers helps you to control your printer licenses.

You can also assign initial variable values to your groups or users. for example, users in different countries
print with the same printing solution but use different (country specific) variable values.

To enable and configure specific user settings:

1. Go to Applications. Click your Application.
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2. In the Authorized Users and Groups section, click on your user or a group. The User Settings
window opens.

3. User settings allows you to enable specific per-user or per-group configuration settings.

4. Enable printer limitation allows you to limit the number of printers your user or group can use.

5. Number of printers is the maximum number of allowed printers per single user or group. If the user
or group exceeds this number, they can't print to additional printers.

WARNING
Each printer used in your shared Application takes one printer license. This setting
makes sure you don't accidentally run out of available printer licenses that come
with your NiceLabel license.

6. Variable values predefine values for certain variables that belong to your shared label or Solution.

These settings override the general settings that you configure for your applications.

4.3. Using File Databases in Applications
Label templates and Solutions in your shared Applications are often connected to a database. Your
connected database works as a dynamic data source for objects on your label templates.

You can choose where to store your database. To ensure your file database (Microsoft Access or Excel) is
accessible from your shared Application, choose one of the following options to store your database:

• Store your database in Control Center > Documents. We recommend storing your label files in the
same folder as your database.
NiceLabel automatically simplifies your database URL in the database connection window:

• Store your database locally on the server that also runs your Web Printing site. Define your database
connection in Desktop Designer as a file path on the server where your database is stored.

• Store your database locally on the computer that runs your Application NiceLabel Web client (Web
Printing) can use your local database.
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NOTE
In case your Control Center can't connect your database (either file database or SQL),
you can access your database directly with Web Client. In this case, start your local
database names with the "LOCAL_" prefix.

When you store your database, connect your label templates or Solutions to your database. Go to NiceLabel
Desktop Designer > Dynamic Data Manager > Database Connections to browse and connect to your
database.

4.4. Sharing Applications with Application Users and
Groups
The Users and Groups pages allow you to instantly share your Applications.

To start sharing Web Applications with your Users:

1. Go to Users tab.

2. Click your user from the Users tab or group from the Groups tab. The configuration page opens.

3. Navigate to the Web Applications section. Click Add.

4. The Add Web Applications dialog opens. All available applications are listed. Select the Application
your want to share.
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5. Click OK.

6. Click Save.

Send a notification email to your users or groups manually. Once your user or members of your added
groups log into http://server/powerformsweb/ (where the server is the name of the server that
hosts your Control Center), they can start using your shared Application.

4.5. Using Applications

Applications give you access to the latest versions of approved label templates and Solutions. Applications
you open automatically update so you can immediately use up-to-date Solutions and print the correct
labels.

Before you start working with shared Applications, install Web Client on your computer. Web Client
installation is necessary only before using the shared web applications for the first time.

1. Open your browser and type this address (your Web Printing URL):
http://server/powerformsweb/

... where server is the name of the server that hosts your Control Center.

2. You land on the Web Printing page. If you haven't installed any Applications before, click the link to
download and install Web Client on your desktop.
If you are an Application user or a member of an Application group, the login window opens. Enter
your user name and password that your Control Center administrator assigned to you.

3. If you are authorized to use more than one Application, the Applications selection dialog asks
you which Application do you want to run. Select the preferred Application and click Run web
application.
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Your Application opens in NiceLabel Web Client and it's ready to use.

If you (an Application User or member of an Application Group) selected the Remember me option (step 3)
while signing in, your Application window displays your user name in the Application's title bar. If there are
other users working with shared Applications on your computer, you can click Sign out (in your user menu)
and the next user must sign in using their own user name and password assigned to them by your Control
Center administrator. By clicking on your user name you access your user menu.

From the user menu, you can:

• Switch between your multiple shared Applications.

• Get notified about minor Web Client updates.

Print operators can access Web Client and your shared Applications by entering your Web Printing URL in
the browser or from their computer's start menu. Depending on your User privileges, you can also access
your Applications from the Login page and from the Control Center's Dashboard page.
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TIP
Make a bookmark in your browser If you receive Applications from different Control Center
deployments.
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5. Integrations

Control Center also enables you centralized management of all Automation configurations and triggers
running on computers connected to Control Center.

5.1. Automation Manager

Automation Manager in Control Center provides you centralized access to all configurations and triggers
running on Automation Servers on your local computers. Automation Manager in Control Center connects
to Automation Manager on your local computers, so you can make changes instantly from your Control
Center.

Large organizations often have multiple Automation servers running different Automation configurations.
When production problems occur, viewing Automation logs on multiple Automation servers is inconvenient,
takes time, requires remote access, and increases security risks.

Automation Manager in Control Center works like your local Automation Manager, but adds computer
names so you can quickly locate your Automation configurations and triggers.

NOTE
Run Automation Manager on local computers or in when possible. Automation Manager
in Control Center works best when you manage many Automation instances. With slow
networks, your changes may take more time to affect Automation servers installed locally.

In Control Center, you can:

• Access all your triggers and see live trigger statuses.

• Start and stop your triggers.

• Load triggers from different configurations from Documents.

• Access all trigger logs to see execution details.

• See triggers with errors or warnings, and get notifications when errors occur (In Administration >
Email Alerts).
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• Add triggers from Documents to your local computers or in .

• Manage users and permissions for adding, editing, viewing, and deleting triggers (In User
Management > Access Roles).

You can centrally manage all your triggers and configurations on all your computers or in with Automation
Manager in Control Center.

5.1.1. Triggers

Automation Manager in Control Center provides you centralized access to all configurations and triggers
running on Automation Servers on your local computers. Automation Manager in Control Center connects
to Automation Manager on your local computers, so you can make changes instantly from your Control
Center.

The Automation page in Control Center is your entry point for monitoring and managing all your Automation
configurations and triggers.

In Control Center, go to Integrations > Automation.

You can:

• Access all your triggers and configurations.

• See which triggers are located on which computers and view Automation logs.

• See time elapsed since the last trigger event.

• See triggers with errors.

• Check trigger statuses:

• Running

• Stopped

• Server Offline

• See configuration names and types.

• Manage all your triggers and configurations:
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• Start and stop your triggers.

• Refresh your trigger list in Control Center.

• Reload your triggers.

• Remove your triggers.

• Copy configurations from Documents in Control Center to Automation Managers on local
computers in your network.

• Sort your trigger list.

• Search your triggers.

• Group your trigger lists by configuration names.

• Group your trigger lists list by server names.

NOTE
If possible, upload and run your Automation configurations from Documents in your Control
Center. This way you enable centralized access to your triggers. You can edit your triggers
from your computer with Control Center and Automation Builder installed.

Click the link in the Configuration name column name to open the trigger location in
Documents.

In Documents, double-click your trigger file to edit it in Automation Builder.

Centralized management of all your Automation triggers saves you time, avoids system downtime, and
minimizes security risks.

5.1.2. Starting and Stopping Triggers

Automation Manager in Control Center provides you centralized access to all configurations and triggers
running on Automation Servers on your local computers. Automation Manager in Control Center connects
to Automation Manager on your local computers, so you can make changes instantly from your Control
Center.
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You can start and stop triggers running on local computers connected to Automation Manager in Control
Center.

NOTE
You can search for triggers by name, Automation computer name, or configuration name.

Starting triggers

To start triggers in Control Center:

1. Go to Integrations > Automation.

2. Check the boxes of triggers you want to start.

3. Click Start.

Your triggers start on your computers. Automation Manager changes your trigger icons from grey to green
to show your triggers are running.

Stopped triggers vs Running triggers

Stopping triggers

To stop triggers in Control Center:

1. Go to Integrations > Automation.

2. Check the boxes of triggers you want to stop.

79



3. Click Stop.

Your triggers stop on your local computers.

5.1.3. Setting Trigger Permissions

You can set Automation configuration and trigger management permissions for your Automation users in
Control Center. Users with permissions can manage configurations and triggers on local computers from
AutomationManager in Control Center.

With permissions set, your users can:

• Start and stop triggers.

• Add configurations.

• Reload and remove configurations.

To enable permissions for users in Control Center:

1. Go to Users > Access Roles.

2. Click the role you want to change.

3. In Permissions for this Role click Applications.

4. Enable Start/Stop triggers, add/remove and reload configurations (Automation Manager, Control
Center).

Users now have permission to manage all triggers listed in Control Center.

5.1.4. Configurations

Automation Manager in Control Center provides you centralized access to all configurations and triggers
running on Automation Servers on your local computers. Automation Manager in Control Center connects
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to Automation Manager on your local computers, so you can make changes instantly from your Control
Center.

From Automation Manager in Control Center, you can add, reload, and remove configurations to and from
Automation servers on local computers.

NOTE
NiceLabel V5 NiceWatch configuration files (.mis) are not supported anymore. Control
Center treats V5 configuration files as an unknown format. You can still open and edit V5
configuration files in the latest Automation.

Adding configurations

You can load Automation configurations from Documents to Automation servers on local computers.
Running configurations on local computers helps you decentralize your automated printing processes and
allows your users to manage Automation configurations.

Users can start, stop, and modify locally stored Automation triggers.

You can also manage all configurations from Control Center.

NOTE
You must store your Automation configurations in Documents.

To add configurations to local computers:

1. In Control Center go to Integrations > Automation.

2. Click Manage configurations.

3. Manage configurations window opens. Click Add.

4. The Documents explorer window opens. Browse to your configuration and click Next: Select
computer.

5. Select the computer where you want to deploy the configuration and click Finish.

Your configuration is now deployed to the Automation server on your local computer.

Reloading configurations

IMPORTANT
When your users change and save configurations in Automation Builder, you must reload
the configurations for them to take effect.
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Reloading configurations in Control Center works the same as reloading configurations in Automation
Manager on local computers. For detailed instructions, read your Automation User Guide.

To reload configurations in Control Center:

1. Go to Integrations > Automation.

2. Click Manage configurations.

3. Manage configurations window opens. Select configurations you want to reload and click Reload.

Your configurations reload. Your new configurations settings now affect your printing.

Removing configurations

Remove configurations from your list in Control Center to prevent running obsolete triggers by mistake.

To remove configurations in Control Center:

1. Go to Integrations > Automation.

2. Click Manage configurations.

3. Manage configurations window opens. Select configurations you want to reload and click Remove.

NOTE
Removing configuration from your list in Control Center doesn't delete configuration files
from your local computers or Documents.

By pressing the Remove button, your configuration is removed from your list. Triggers from removed
configurations are no longer listed.

5.1.5. Automation Logs

Automation Manager in Control Center provides you centralized access to all configurations and triggers
running on Automation Servers on your local computers. Automation Manager in Control Center connects
to Automation Manager on your local computers, so you can make changes instantly from your Control
Center.

You can check and filter Automation logs for triggers running in Automation Managers on local computers
connected to Control Center. Automation logs all activities to a local database so you can view history and
troubleshoot trigger executions.

Your Logs pane displays information for all events related to filters you apply.

To check and filter triggers in Control Center:
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1. Go to Integrations > Automation.

2. Search for your trigger in your trigger list and click Logs (in the Trigger name column).

3. Your logs window opens. You can filter your logs by:

• Log period (time periods): predefined or custom

• Event level: Error, Warning, or Information

4. Click the + icons to the left of your log timestamps to see events and action details (like
information, warnings, and errors) in your log files.

Expanded log from your current day. Only logs with errors and warnings are shown.

You can also search by event description.

By pressing the Copy log button, you can copy a text file with log events of the trigger or isolated action to
your desktop.

The Download button enables you to create an Excel file with all logged events in your Log period.

You can reset the errors counter in Control Center by clicking the  icon.
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If you run Automation on a local computer, the counter resets also in local Automation Manager. Resetting
the counter doesn't remove errors from the log.

Check your Automation logs to troubleshoot problems. If you cannot execute your triggers or actions,
Automation records error descriptions in your log files to help you identify and resolve issues.

5.2. NiceLabel Automation integration with Loftware
Integration - Oracle EBS

5.2.1. About Loftware Integration - Oracle EBS and integration with
NiceLabel Automation

Loftware Integration - Oracle EBS (formerly Loftware Oracle Agent) is a component that enables
supported Loftware solutions to integrate with Oracle® E-Business Suite (EBS) so that Oracle® Warehouse
Management (WMS) applications can receive and process label print requests. Loftware Integration -
Oracle EBS can be updated independently of the Loftware solution, ensuring that the solution can have the
most up-to-date integration capabilities available.

An Oracle administrator installs Loftware Integration - Oracle EBS in the Oracle EBS system database and
configures it to securely connect with a Loftware solution. An administrator of the Loftware solution can
configure an Oracle integration for use with label templates without needing to enter Oracle credentials.

This guide helps you to deploy the NiceLabel Automation configuration to support the Loftware Integration -
Oracle EBS and explains the integration processes.

The latest Loftware Integration - Oracle EBS version natively supports NiceLabel.
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How to obtain the software?

If you are a new customer interested in Loftware Integration - Oracle EBS, or an existing NiceLabel
customer interested in using Loftware Integration - Oracle EBS in conjunction with NiceLabel, contact
Loftware Sales.

The Automation integration .zip file contains:

• NiceLabel Automation configuration (.misx file)

NOTE
NiceLabel Automation is an application that automates repetitive tasks.

Learn more about NiceLabel Automation.

• NiceLabel Automation integration with Loftware Integration - Oracle EBS guide

Before you start, check the System Requirements.

5.2.2. System requirements

Loftware Integration - Oracle EBS

For a successful integration, the requirements for Loftware Integration - Oracle EBS are:

• Oracle Database 19c

• The Loftware Integration - Oracle EBS must be installed in your Oracle EBS database. For a detailed
installation process, see the Getting Started with Loftware Integration - Oracle EBS.

NiceLabel

For a successful integration, the requirements for NiceLabel are:

• NiceLabel installation:

• LMS Enterprise 10.5 or later

• NiceLabel Automation prerequisites:

• Printer drivers must be installed. You can install printer drivers directly on your computer, or you
can register the drivers from the print server you may have.
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NOTE
For the best printing experience, we recommend you install Loftware printer
drivers.

To install Loftware printer drivers, see the Printer driver installation guide.

If you already have printer manufacturer's drivers, you can replace them with
Loftware printer drivers to optimize your printing process.

If you already have Loftware printer drivers, we recommend you update them to
the latest versions. See Updating printer drivers.

• The user account that the NiceLabel Automation Service runs from, must have read permission
to the folder or folders in Document Storage, where labels are stored.

• All printers must be visible to the computer and the user account under which the Automation
Service runs. Automation creates print jobs on this computer and sends them to the printers
using Windows Spooler. The printers must be accessible for printing for the user account under
which Automation Service runs. Make sure to use a real user account when using network
printers (do not use a Local System Account).

• Other NiceLabel System requirements.

5.2.3. Software overview

NiceLabel

Your NiceLabel product allows you to create and edit labels (Desktop Designer), have access to document
storage with versioning, approval processes, user management, and print history (Control Center) and
provides an integration system (Automation).

Your NiceLabel product contains:

• NiceLabel Desktop Designer is an application for designing and printing labels. Install Desktop
Designer on your computer and connect it to Control Center. In Control Center, you can see all your
printers connected to your Desktop Designer.

• NiceLabel Control Center is a cloud-based application that allows you to share and store your labeling
files and print labels. Control Center connects all printers of all users who have their Desktop Designer
connected to Control Center.

• NiceLabel Automation is an application that automates repetitive tasks like automated printing.

When NiceLabel Automation receives a data payload from the Loftware Integration - Oracle EBS, it first
fetches the correct label from Documents in Control Center, populates the fields in the template with the
business data provided in the Oracle payload, and prints a label to the requested label printer.
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NiceLabel Automation exposes the HTTP REST APIs that are consumed by Loftware Integration - Oracle
EBS. NiceLabel Automation synchronously sends the response for each call.

NiceLabel Automation

The integration bundle provides a pre-built NiceLabel Automation connector (trigger). You deploy
the provided Automation configuration (.zip file) and start the trigger. The NiceLabel Automation
configuration contains one Cloud Trigger that provides the API endpoint for the Loftware Integration -
Oracle EBS.

The action in a trigger is based on the built-in action Run Oracle XML Command File. This action can parse
the XML payload from the Loftware Integration - Oracle EBS and execute the print actions accordingly.

All actions before this one are there to ensure the label names in the XML include a full URL prefix to the
location in your Documents page in Control Center. The URL is read from the NiceLabel configuration file
and appended into the XML payload.

After the actions in the trigger are complete, a JSON response is sent back to the Loftware Integration -
Oracle EBS.

Designing labels in NiceLabel Desktop Designer

With NiceLabel Desktop Designer you can create and edit labels and connect them to dynamic data
sources. See how to create a new label in Desktop Designer.

When Loftware Integration - Oracle EBS consumes the NiceLabel API, it provides the JSON payload with the
data for NiceLabel Automation, including key-value pairs for the label variables.

Each label, connected to a dynamic data source, contains the variables as data sources for the label
objects. These variables connect to label objects and provide values for those objects at print time.
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The variables defined in the label must have the same names as the data fields in the Oracle applications.
You can create variables in the label manually, but you can also import variables from the existing labels or
the Oracle XML payloads.

Label referencing names

You must store your labels in the Documents in your Control Center. Reference the name of your labels
from the root folder in Documents.
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For example, if you have a label label.nlbl stored in a folder called Labels , which is in the Project1
folder; the correct form of the full path to the template is /Project1/Labels/label.nlbl.

If you don't provide the full name to the label templates in Documents in your Control Center, including the
full path to the label template, Automation has to find a label template:

• the same folder where MISX is stored

• folder .\Labels

• folder ..\Labels

• default label folder

See Using project folders to manage files needed on the label or form for more information.

5.2.4. Integration setup

Deploying NiceLabel Automation

To deploy the pre-configured Automation configuration, you must load it into NiceLabel Automation
Manager and start the triggers.

Installing and activating NiceLabel Automation

NiceLabel Automation is part of NiceLabel desktop applications installation. The required module to run the
Automation configurations is "Automation."

For more details, see the NiceLabel installation guide.
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For activating NiceLabel Automation, see Licensing and activating NiceLabel.

Deploying triggers in Automation

Before you can start deploying triggers, make sure you have NiceLabel Automation installed on your
computer and that your NiceLabel product is activated.

For activating LMS Enterprise, see Activating NiceLabel LMS Pro/LMS Enterprise and signing in to License
Center.

1. Extract the .zip file to a folder in Documents in your Control Center.

2. Run NiceLabel Automation Manager.

3. Go to Triggers, then click the +Add button.

4. In the Open window, browse for your .misx file and click Open.

Automation Manager loads the configuration and lists the triggers in the right-hand pane.

5. Select all triggers and click Start on any of the triggers. All triggers will start. Triggers’ icons turn
green, and the status changes to “Running.”

IMPORTANT
Once started, the triggers will automatically start upon the server reboot.
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5.2.5. Authentication for NiceLabel APIs

The URL endpoint for NiceLabel on-premise products is custom (on your server), but you still need an
integrator key to authenticate the call to the API.

NOTE
Your NiceLabel integrator key can be created before or after Loftware Integration - Oracle
EBS is installed.

To generate the integrator key:

1. In your browser, open your local Control Center. The URL is custom for your installation, for
example, http(s)://<YourServerName>/epm.

Replace <YourServerName> with the name or IP address of your server where your Control Center is
installed.

NOTE
Using either http or https depends on whether your web server enables encryption.

2. Go to Integrations > Cloud integrations.

3. Click Add.

4. Type in the name of the integrator. The integrator key is auto-generated.

5. Click Save.
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5.2.6. API endpoints

To consume the API, use the following URL:

API URL

Loftware Integration - Oracle EBS trigger http(s)://<YourServerName>/epm/api/trigger/Api-
OracleEbs

Each API request must include a custom header with the name Integrator-Key. Its value is the subscription
key obtained in Authentication for NiceLabel APIs.

Replace <YourServerName> with the name or IP address of the server where your NiceLabel Control Center
is installed.

Using either http or https depends on whether your web server enables encryption.
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6. Printers

NOTE
With Essentials LMS Pro license you can't manage your printers, but you can see Cloud
printers and Licensed printers details and monitor printer activities.

Manage all your label printers, printer drivers, print jobs, and printing preferences for your entire system,
all in one place.

Control Center helps you manage and expand your entire label printing system securely from your
browser. From Control Center, you upload your printer drivers, connect printers, and install and update
printers and drivers to computers in your system. Use printer groups to control who can access and
manage specific printers. View your entire label printing system from Control Center, including current print
jobs in all your queues, errors, required updates, and printer and computer statuses.

As part of NiceLabelLabel Management System, Control Center integrates into your IT environment to give
you secure browser-based central print management of your entire labeling printing system.

• Global IT Administrators manage global printer installation, updates, settings, profiles, groups,
licensing, and drivers, while centrally monitoring labeling in multiple locations.

• Local IT Administrators manage local printer installation, provisioning, configuration, updates,
settings, profiles, groups, and drivers while monitoring labeling in single locations to keep production
running.

• Print Operators adjust printing preferences for one or more label printers on your production lines in
single locations to print labels.

Printer management helps you avoid downtime by maintaining and overseeing your entire label printing
system from your browser, and helps you organize and expand labeling systems large and small.

NOTE
Centrally-managed printers are printers you operate and control from Control Center.
When you add printers to Control Center, you can update printing preferences and printer
installations from Control Center instead of using printer drivers on individual computers.

How Printer Management helps

Without Printer Management, when you buy a new label printer for your production facility and plug it in,
you have to manually call your IT manager to remotely connect your TCP/IP printer to your network. Once
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connected, to install your TCP/IP printer on the computer that runs your factory printers, you have to walk
to the computer, download and install a printer driver, then install your connected printer with the driver on
your computer. You have to repeat this process for each new printer and each time you want to update
driver settings (like speed or darkness) for your printers or update your printer drivers.

With Printer Management, you can add your new TCP/IP printer to Control Center from any computer on
your system. You upload the Loftware printer driver for your printer to Control Center and install the printer
with the driver on the computer that runs your factory printers remotely. Now, you can install your new
printers, update driver settings for your printers, and update your printer drivers in Control Center from
anywhere.

How Printer Management reduces complexity

Your company has a large printing system with multiple locations and multiple NiceLabel products
installed. You have 50 TCP/IP label printers already connected to your system, and you want to install
a new printer. You want to print from NiceLabel Automation on your 2 dedicated Automation servers where
you have NiceLabel installed. You need to physically go to or remotely access the 2 servers (computers)
and install your new printer (connected to your network via TCP/IP). On each computer, you go to the
Loftware website, download the latest printer driver package for your printer, and use the driver package to
successfully install your new printer.

In 6 months, you want to install more new printers on one of your computers. Again you have to go to
your computer, go back to the Loftware website, download the latest driver packages for your new printers,
and install your printers. The Loftware printer driver already running on your computer recognizes you're
downloading a newer driver version and updates the driver for the previously installed printer without your
knowledge. If you install a printer from a different manufacturer, when you download a new Loftware driver
major release update, your previously installed driver also upgrades. Upgrading requires your computer to
restart its spooler service, causing your production lines to stop. Because you have multiple computers
in your environment and your computers run printers in multiple locations, that means production may
stop in multiple factories. The other computer you didn't update still runs older driver versions to print on
the same printers. You want to print the same label from multiple automation servers, but now they print
correctly from one computer but not the other. When you investigate, you realize the problem is different
driver versions. You have to do all that on a remote connection while running Control Center in a confined
environment.

To avoid problems in your complex system, you decide to use Printer Management to install printers using
the correct printer drivers while keeping your entire printing environment updated automatically so all your
computers use the same updated versions of all your drivers.

6.1. The Printers interface
Go to Control Center > Printers > Overview to see information about your centrally managed printing
environment, recent provisioning operations, and your list of print queues.
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The Printers > Overview page includes:

1. Additional tabs you can click to see detailed information and take more actions:

• Overview

• Printers

• Cloud Printers connect directly to our Cloud Printing service without drivers. You can view
cloud printers in Control Center, but you can't manage or install them.

• Computers

• Profiles

• Groups

• Driver Packages

• Licensed Printers

2. Details about your printing Environment, including how many Printers, Computers, Profiles, and
Driver Packages you have connected to Control Center. Click the links to visit relevant tabs.
Click Details to open your detailed list of centrally managed printers in your system.

3. Recent Provisioning Operations.

4. Your list of centrally-managed Print Queues.
A print queue is a virtual concept~a holding area for storing spooled print jobs while the printer is
trying to catch up. You don't actually send print jobs to printers, you send them to print queues until
printers start printing at print time. A print queue doesn't require a printer~ it continues to accept
jobs while the printer is offline (like while being repaired).
For more information, read Print Queues in Section 6.7, “Computers”.

95



6.2. Printer vocabulary

Printer vocabulary

Printer A printer is a physical hardware device~ the actual printer that prints out labels,
tickets, or tags.

Types of printers:

• Local printers are printers directly connected to computers with cables like
USB or serial ports. You can't install or manage local printers in Control
Center.

• Network printers are printers that connect to computers via TCP/IP (RAW
or LPR/LPD) or network ports. Network printers are the printers you can
centrally manage in Control Center.

• Shared printers are printers you install on print servers and mark as "shared"
in your system. You can view and manage shared printers in Control Center,
but you can't install shared printers using Control Center.

Centrally
Managed
printer

A centrally managed printer is a printer that is operated and controlled by Control
Center. When you add a printer to Control Center, you can manage printing
preferences and printer installation from Control Center.

Computer A computer is a machine that connects to printers and sends printers data and
instructions to print out labels.

Computers can be:

• Desktop or laptop computers.

• Servers or virtual machines.

Printer driver A printer driver is a piece of software that allows computers to communicate with
printers and send print requests. Printer drivers have two main functions:

• Serving as a bridge between the computer and the printer, allowing the
computer to understand the details and hardware specifications of the printer.

• Transforming print job data into a language the printer can understand. Each
printer has a unique driver written in printer-specific language for that printer
model and manufacturer.

Driver
package

A driver package is a compressed (zipped) bundle of the all files you need (like .inf
and .dll files) to install printer drivers on Windows for a specific manufacturer. When
you download your driver packages for free from Loftware, you're downloading
a bundle of all the drivers for all the supported printer models of that specific
manufacturer.

Preferred
driver

A preferred driver is the printer driver package you choose to install and use
specific printers or groups of printers and for generating centrally managed printing
preferences for those printers.
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Print job A print job is a document or set of documents you send to a print queue to be
printed.

Print queue A print queue is a virtual concept~a holding area for storing spooled print jobs
while the printer is trying to catch up. You don't actually send print jobs to printers,
you send them to print queues until printers start printing at print time. A print
queue doesn't require a printer~ it continues to accept jobs while the printer is
offline (like while being repaired).

Installed
printer

An installed printer is a printer connected to a computer with a driver through
an installation process. You start the process by installing a printer driver on a
computer and using it to create a print queue. When you browse "installed" printers
in your Windows Control Panel, you aren't actually viewing printers, you're viewing
the print queues your drivers create on your computer during the installation
process. You can manage this process centrally for your computers, printers, and
driver packages in Control Center.

Printing
preferences

Printing preferences are the instructions that tell each printer how to print labels.
Printing preferences include settings for printing media like media size, media type,
and rotation. Printing preferences may also include more printing settings (like
speed and darkness) depending on your printer model.

Driver profile A driver profile is a set of printing preferences linked to a specific printer driver.
Putting printing preferences in profiles allows many printers to share the same set
of printing preferences without the need for duplication.

Printer model A printer model is a name given by the printer manufacturer to a type of physical
printer device.

Group Use groups to organize your computers and printers into logical structures that
reflect the structure of your printing environment or setup. Use groups to define
access rights and give only certain users access to your computers and printers.

6.3. How printer management works
Printing preferences

Printing preferences are the instructions that tell each printer how to print labels. Printing preferences
include settings for printing media like media size, media type, and rotation. Printing preferences may also
include more printing settings (like speed and darkness) depending on your printer model.

With previous versions, you stored your printing preferences in NiceLabel inside individual label templates
or within printer drivers on individual computers. This approach wasn't good enough for enterprise
environments with thousands of labels, because each change you made to printing preferences had to
be applied to all the labels. If you had your printing preferences stored in drivers on computers, then each
change to printing preferences had to be applied individually on each computer you printed from.

Now, when you print on centrally managed printers from Control Center, you can instruct your printer to
use printing preferences stored in Control Center. If you still have printing preferences stored in your label
or locally on the computer that sends the print command, you now have the option to override those
preferences and apply the preferences stored in Control Center instead.
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Control Center applies your stored printing preferences in DEVMODE at print time. When computers send
print commands to centrally managed printers, Control Center replaces the printing preferences computers
send with print their commands with the DEVMODE printing preferences stored in Control Center. You can
edit printing preferences directly in Control Center with a GUI editor if you use Loftware version 10 printer
drivers or newer. Older printer drivers require raw DEVMODE strings.

Printer installation process

Typically, printing environments have TCP/IP printers installed on computers. To print a label, you need:

• NiceLabel installed on a computer.

• Your printer.

• Your printer driver (uploaded to Control Center).

To print labels, you need to add your printer to Control Center and install it on your computer from Control
Center along with your printer driver.

• Adding printers to Control Center means saving printer properties like printer name and IP address in
Control Center. With your printers added, you can install them.

• Installing printers from Control Center means sending your printer information (like IP address and
name) along with the printer driver required for your printer from Control Center to your computer for
installation.

During installation, when your computer receives the driver and printer information, NiceLabel uses the
driver to create a print queue on your computer. On your computer, the NiceLabel Proxy service 10
(which installs on your computer when you install NiceLabel 10) receives the driver and printer information
and installs the printer. The NiceLabel Proxy service enables necessary communication between printers,
Control Center, and NiceLabel applications installed on individual computers in your printing environment.

From Control Center, once your printers are installed, you can centrally:

• Delete print queues.

• Clear, pause, and resume print queues.

• Update your printer drivers.

6.4. Setup

Printer Management is a new way to organize your entire labeling system. You can manage updates and
printing on all your printers, computers, and drivers centrally from Control Center. Printer Management
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requires special setup to integrate your printers, driver packages, and computers into a single system
before you can print.

NOTE
To use all printer management features and centrally manage your printers, update your
Control Center and NiceLabel applications to the latest version. For more information, read
Section 6.5, “Migrating from previous versions”.

1. On computers you want to print from, install any NiceLabel desktop application and sign in to your
account. Signing in connects your computer to Control Center and makes it available for centralized
Printer Management.

2. Add printer driver packages for your printers. Centralized Printer Management only works with
Loftware printer drivers. For more information, read Section 6.10, “Driver Packages”.

3. Add your printers to Control Center. Printers you add still need to be installed with drivers on
computers. For more information, read Section 6.6, “Managing printers”.

4. Install your printers with their respective drivers on computers you choose. For more information,
read Section 6.6, “Managing printers”.

NOTE
When you upgrade from previous versions of Control Center, your detailed list of printers
appears empty when you open Control Center > Printers > Overview for the first time, but all
your existing printers are still in your system.

Go to Printers > Printers and click Add. From the drop-down menu, choose Search for more
printers in my environment to see all your printers and choose which printers to centrally
manage from Control Center. For more information on adding centrally-managed printers,
read Section 6.6.1, “Adding printers”.

With your printers, drivers, and computers set up, you can centrally manage your printing, change printing
preferences, and keep your drivers up to date from anywhere in Control Center.

6.5. Migrating from previous versions

Install the latest version of NiceLabel software on your computers to use all new features including
centralized Printer Management.

Print management data
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Legacy print management data does not automatically migrate from previous versions. Follow this process
to migrate your Printer Management data to Control Center:

1. Update all your NiceLabel applications to the new version. Make sure they're still connected to
Control Center.

2. Open Control Center > Printers > Printers.

3. Click Add > Search for more printers in my environment.

4. Select your printers and follow the Import Printers wizard. The wizard attempts to select a
group based on your legacy print management data. If your printers aren't available, wait for your
computers to report printer data to Control Center.

For more information, read Section 6.4, “Setup”.

Limitations and differences:

• Legacy print management groups included printer queues. Now, Section 6.9, “Groups” include printer
devices.

• Print queues could belong to multiple groups in legacy print management. Now, printers belong to just
one group.

• Legacy print management supported dynamic groups (by printer name or status). Now, group
membership is static.

• Imported printer groups are based on static groups. If no static groups are available, Control Center
tries to import dynamic groups (only by printer name, not by status).

Control Center database backward compatibility

NOTE
Create a database backup before you upgrade to NiceLabel 10.

The NiceLabel 10 database is not 100% compatible with previous versions. This means that you can't
revert to the previous versions of Control Center once you upgrade your database.

6.6. Managing printers

Get real-time updates and make changes on every printer in your system from one place.
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NOTE
You might not see all the options for managing printers in your Control Center > Printers
page because of insufficient user rights.

Check the permissions with Control Center administrator in Users > Access Roles.

Add your printers to Control Center to centrally manage your printing system from your browser for
improved efficiency and reduced maintenance time. Printer Management helps you keep your local
production lines running smoothly by installing and managing printers in local domains without having
to consult your global IT manager. Install printers you add on your computers with the correct Loftware
printer drivers to choose printing preferences, monitor your printing system, manage updates, organize
printers with profiles, and assign access and permissions with printer groups.

NOTE
You can centrally manage Network printers connected to computers via TCP/IP (RAW or
LPR/LPD) or network ports with Printer Management. Consider using Printer management
if your printing operations require at least a few hundred printers. See the troubleshooting
topic if you can't see your printers in Control Center.

For more information, read the "Printer" definition in the Printer vocabulary.

Add and install new printers or import your existing installed printers before you can manage them from
Control Center.

Go to Printers > Printers to see your list of added centrally-managed printers and sort your printer information.
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Click on printer names to view and update printer information, printer settings (including printer preferences), status, and print queues.

Monitor and update all your centrally-managed printers from Control Center to reduce downtime and
prevent problems.

6.6.1. Adding printers

Add your printers to Control Center before you install them on your computers. You can manually add
TCP/IP printers, or automatically find printers in your system and choose which printers to add.

Adding printers manually (TCP/IP)

TCP/IP printers provide a raw TCP port for your printing data. Most printer manufacturers use port 9100.

NOTE
We recommend using advanced port monitor and TCP/IP(RAW) printing protocol when
supported by your printer.

1. Go to Control Center > Printers > Printers and click Add.

2. From the dropdown menu, choose Manually add TCP/IP printer. The Manually add TCP/IP printer
window opens.
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3. Type your printer information and click Add.

4. (Optional) To add LPR printers:

a. Click Show advanced connection properties.

b. For Port Monitor, choose Standard TCP/IP Port.

c. For Printing protocol, choose LPR. The LPR queue name field appears.

d. Type in your LPR queue name.

e. Click Add.

Your new TCP/IP printer appears in your list of centrally managed printers. Now you can install your added
printer on your computers.
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Adding printers automatically with Import Printers

Find existing printers connected to computers in your system to add to Control Center.

1. Go to Control Center > Printers > Printers and click Add.

2. From the dropdown menu, choose Search for printers in my environment. The Import Printers
window opens.

3. In Select Printers, from the dropdown menu, choose your computer to see printers from that
computer. Use Filters (on your right) to narrow your selection and find printers to add.

4. Select printer(s) to add, and click Next.

5. In Modify Printer Settings, select your printers to apply settings:
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a. Click Set group to add your printers to an existing printer group from the drop-down menu.
Read more about printer groups: Section 6.9, “Groups”.

b. Click Set preferred driver package to connect your printers with an uploaded driver
package from the drop-down menu. Setting a preferred driver package to use this driver
package to control printing preferences and future installations on other computers.
If your preferred Loftware drivers are version 10 or newer, you can update printing
preferences directly in Control Center. If you choose to use older preferred driver versions,
you may not be able to change your printing preferences directly in Control Center without
DEVMODE.
Read more about drivers: Section 6.10, “Driver Packages”.

NOTE
Your selected printers must be from the same manufacturer to set shared
drivers. You can't connect printer drivers with printers from different
manufacturers.

6. Click Finish to add your printers.

Importing printers from Excel

You can enter a list of your printers in a predefined Excel template and then import the Excel file in Control
Center. This way you simplify entering each printer's data individually.

You can also use the Excel table if you don't have user rights to install printers in Control Center. You can
send the Excel file to the Control Center administrator who can import the Excel file and install printers.

Your Excel file contains the following printer data:

• Printer name

• IP address

• Port number

• Port monitor type

• Group

• Manufacturer

• Printer model

• Driver package

To generate the Excel file and import printer data:

1. Go to Control Center > Printers > Printers and click Add.

2. From the drop-down menu, choose Import from Excel. The Excel Import window opens.
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3. Click the Download button. The Excel template Printers-import.xlsx saves to your local disc.
The Excel file already contains data about your existing driver packages, groups, and port monitors.

4. Open the downloaded Printers-import.xlsx and go to Printers sheet. Enter your printers'
data into green columns (Printer name, Description,...). Copy the values from other sheets in blue
columns (Port Monitor, Group,...)

WARNING
Printers-import.xlsx compares the data in the Printers sheet (blue
columns) to data in other sheets. If data don't match, the Package check column
shows an error.

You can't insert driver packages data that is not stored in Control Center.

WARNING
If you later add additional printers with Excel, create a new Excel file with only new
printer data. Control Center will not import an Excel file with the existing printers.

5. Upload your Excel file to Control Center and click Next: Modify Printer Settings.
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6. In this step, you can change groups or preferred driver packages for selected printers.
(You can also change these properties later in Control Center.)

NOTE
If you get errors, you can modify your data by clicking to the field where error
occurs.

You can't delete the whole printer record.

7. Click Finish to add your printers.

Your installed printers are imported and appear in your list of printers. Now you can manage printing
preferences for your printer or install your printers on other computers.

6.6.2. Installing printers

Install your added printers on computers in your system with uploaded driver packages before you can
centrally manage your printing preferences, see printer statuses, and manage print queues from Control
Center.

• Before you install printers, connect your computers to Control Center. Read more in Section 6.7,
“Computers”.

• Before you install printers, upload your driver packages to Control Center. Read more in
Section 6.10, “Driver Packages”.

An installed printer is a printer connected to a computer with a driver through an installation process. You
start the process by installing a printer driver on a computer and using it to create a print queue. When
you browse "installed" printers in your Windows Control Panel, you aren't actually viewing printers, you're
viewing the print queues your drivers create on your computer during the installation process. You can
manage this process centrally for your computers, printers, and driver packages in Control Center.

1. Go to Control Center > Printers > Printers and click Install Printers. The Install Printers window
opens.
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NOTE
If you can't click Install Printers you may need installation rights for this printer, or
the printer may be shared.

A user that runs the NiceLabel Proxy service, must have rights to install printers.

2. Select which printers to install and click Next. If you don't see your printer, click Refresh to update
your list of available printers.

NOTE
You can't install printers without Loftware printer drivers. Read more about drivers:
Section 6.10, “Driver Packages”.

3. Choose the computers to install your printers on and click Next.

NOTE
You can install printers on offline computers marked "Ready when online".
Installation begins when these computers come back online.

NOTE
You can't install printers on computers using older versions of Desktop Designer, for
example V2019 or V2017. Such computers are greyed out in the list of computers.
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4. Review or update your printer queue and port configurations, and click Next.

NOTE
You may not be able to edit some printer queue names.

5. Select a printer driver package for each printer family from your uploaded drivers and click Next.
Toggle + and - (on your left) to see more details and the effects your installation may have on your
system.
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NOTE
Using different driver versions for the same printer families may produce conflicts.

When you select your driver package, your printer Status updates. Check your status before you
install your printer:

a. Installs new printer. No side effects.

b. Updates printer driver. Requires print spooler restart. Interrupts printing in progress.

c. Updates printer driver. Update also affects this unselected print queue.

d. This printer uses a different preferred driver package. Installing this driver package may
affect printing preferences and print queues or cause errors.

6. Review your settings and choose whether to allow your installation to restart printer spoolers.
Choosing Yes may affect current print jobs in your queue. If turned off, changes take effect after
your computer restarts.

7. Click Install now to install your printers on your computers with your drivers.

Your printer installation begins. You can see your installation status in Printers > Overview > Provisioning
Operations. For more information, read Section 6.6.5, “Provisioning Operations”.

6.6.3. Managing Printing Preferences

Printing preferences are the instructions that tell each printer how to print labels. Printing preferences
include settings for printing media like media size, media type, and rotation. Printing preferences may also
include more printing settings (like speed and darkness) depending on your printer model.
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With Printer Management, you can update printing preferences for all your installed printers instantly in
Control Center. When your printer operators want to update settings, they don't need access to computers
or any additional system permissions to change printing preferences. You can give printer operators
permission to edit printing preferences for specific printers, computers, driver packages, or printer profiles
in Control Center. When your printer operators log in to Control Center and update printing preferences for
their printers, the changes take place immediately and reduce printing downtime.

To manage printing preferences, go to Printers > Printers and click on a Printer name to update. The
Printer page opens:

Use the tabs (on your top left) to update your printer settings, then click Save all to apply your updates:

• Summary: view and update general printer information.

• Under Printer information, edit the fields to update your Printer name, Description, Group, and
Preferred driver for this printer to use for setting printing preferences and future installations.
If your preferred Loftware drivers are version 10 or newer, you can update printing preferences
directly in Control Center. If you choose to use older preferred driver versions, you may not be
able to change your printing preferences directly in Control Center without DEVMODE.

• Click the link under Installed on to view computers with print queues for this printer.

• Under License, check if your printer is licensed and/or reserved. For more information, read
Section 6.11, “Licensed printers”.

• Settings: choose how to manage printing preferences for your printer.

• Toggle Centralized settings to save your centrally-managed printing preferences in Control
Center or locally on your printer or label.
Now, when you print on centrally managed printers from Control Center, you can instruct your
printer to use printing preferences stored in Control Center. If you still have printing preferences
stored in your label or locally on the computer that sends the print command, you now have the
option to override those preferences and apply the preferences stored in Control Center instead.

• Use shared settings profile. Applies settings from the shared printer profile you choose from the
drop-down list to your printer. For more information, read Section 6.8, “Profiles”.
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• Use printer-specific preferences. Configure printing preferences like print speed, darkness,
offsets, and more for your printer directly in Control Center. Available settings depend on
your printer model and printer driver version. Some driver versions require adding printing
preferences with DEVMODE.
Set your preferred printer driver to the latest version to use printer-specific preferences.

• Status: view your current printer status including availability and errors.

• Print queues: view queues statuses and pause, resume, clear, and delete print queues for your printer.

Managing your printers centrally in Control Center helps you install, monitor, and update your printers and
settings from one place.

6.6.3.1. Managing Printing Preferences with DEVMODE

NOTE
To centrally manage your printing preferences directly in Control Center with a GUI, use
Loftware printer drivers version 10 or newer.

Older printer driver versions have no GUI support in Control Center, but you can still import and share
printing preferences for your printers by downloading the Get Printer Settings utility for free from our
NiceLabel utilities page. This method allows you to set your printing preferences directly on your NiceLabel
printer driver installed on your computer, copy these settings with Get Printer Settings, and paste your
preferences into Control Center. When you paste your preferences into Control Center, you can apply them
to specific printers or printer profiles to share on multiple models of the same printer.

Get Printer Settings is a simple utility for extracting printer settings from WIndows for printers you select
and saving those settings to file or providing settings in the GUI. This structure is called DEVMODE.
DEVMODE is a binary data structure that includes all settings available in the printer driver. For more
information, see Understanding Printer Settings and DEVMODE topic in Automation User Guide

Control Center applies your stored printing preferences in DEVMODE at print time. When computers send
print commands to centrally managed printers, Control Center replaces the printing preferences computers
send with print their commands with the DEVMODE printing preferences stored in Control Center. You can
edit printing preferences directly in Control Center with a GUI editor if you use Loftware version 10 printer
drivers or newer. Older printer drivers require raw DEVMODE strings.

To use printer-specific preferences with older Loftware printer driver versions:

1. If you want to install new printers, add your preferred version of the printer driver package you want
to use for setting printing preferences to Control Center. If you're not installing new printers, you can
add DEVMODE printing preference strings without uploading driver packages or setting a preferred
driver.
To avoid potential printing errors, make sure the driver package version you upload matches the
driver package you have downloaded on your computer where your printer is installed. This is the
printer driver you use to generate DEVMODE strings.
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We recommend updating the driver on your computer with the latest version of your printer driver
from our driver downloads page and uploading the same version to Control Center to set as
your preferred driver. You use your preferred driver to install and manage preferences for multiple
printers of the same model in your environment.

2. On the computer where your printer is installed with your Loftware printer driver, go to Windows >
Settings > Printers & scanners.

a. Select the printer you want to update and click Manage.

b. The printer page opens. Click Printing preferences.
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3. The Printing Preferences page opens for your Loftware printer driver. Use the tabs on your left to
navigate and update your preferences for this printer. The preferences you will choose act as a
template for other printers in Control Center.

NOTE
Available printer preferences depend on your printer driver version.

Click OK to save your updated printing preferences.

4. Download the free GetPrinterSettings utility .zip package from https://www.loftware.com/
customer-center/downloads/nicelabel-utilities.

a. Extract and run GetPrinterSettings.exe. The Get Printer Settings window opens.

b. Select your printer from the dropdown list.
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c. Click Get Printer Settings to generate your DEVMODE text string of saved printing
preferences. Click Copy to Clipboard to copy your string.

5. In Control Center, go to Printers > Printers and click the Printer name of the printer to update. The
Printer page opens.

6. Under Printer Information > Preferred driver, choose your uploaded driver version as your preferred
driver from the dropdown list.

7. Open the Settings tab.
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a. Activate Centralized settings.

b. Select Use printer specific preferences.

c. Under Printing preferences (DevMode), paste your DEVMODE string.

d. Click Save all.

Your printing preferences from your printer driver are saved in Control Center.

6.6.3.2. Using DEVMODE Printing Preferences in Profiles

Use the same process to add DEVMODE strings of saved printing preferences to new printer profiles. Apply
your saved DEVMODE printing preferences to multiple printers of the same model in your environment by
adding your printers to the profiles you create.

Create your profile following the instructions on Section 6.8, “Profiles”:

1. Add your Printer Information.

2. Use GetPrinterSettings to paste the Printing preferences from your printer driver on your computer
as a DEVMODE string.

3. Click Save to create your profile.
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Your printing preferences are saved in your new printer profile. You can now add printers of the same make
and model to this profile to apply your printing preferences when you print. For more information, read
Section 6.8, “Profiles”.

6.6.4. Environment

Your printing Environment page gives you a detailed view of your centrally managed printers so you can
understand your overall printing system, ensure consistent printing results from different printers, and
minimize the chance of downtime.

Use your printing Environment page to:

• Consolidate drivers you use across your system.

• Know which driver to install before beginning installation.

• Upgrade multiple printers at once.

Go to Control Center > Printers > Overview to see an overview of Your Environment.

Your Environment shows the number of Printers, Computers, Profiles, and Driver Packages in your system.
Click the links to go to the associated pages.

Click Details to open your Environment page.
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Your Environment page shows a list of your centrally managed printers installed on connected computers.
Each row represents one installed print queue.

Drag and drop column headers to group by one or more columns and refine your view. Columns include:

• Printer manufacturer

• Driver provider

• Printer model

• Printer

• Computer

• Print queue name

• Printer type

• Address

• Print queue driver version

• Driver package (Driver version)

• Printer preferred driver package (Driver name)

Use the Environments page to get more information about your entire printing system and to avoid errors
while maintaining, updating, and installing printers and printer drivers.

6.6.4.1. Consolidating printer drivers

Using different printer drivers in your printing environment may cause inconsistencies in your printing
output. Use the Environment page to identify different driver versions on printers in your system so you can
consolidate them into a single driver version for consistent printing results.
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To consolidate your printer drivers:

1. Go to Control Center > Printers > Overview > Environment.

2. On your list, drag and drop the Printer model column header to group by printer model.

3. Under Print queue driver version, look for computers running outdated driver versions. Update the
older printer driver so all your labels print consistently on all printers.

4. To update your driver, install your printer on any computers running outdated versions using the
Install Printers wizard.

a. Go to Control Center > Printers > Printers and click Install Printers. The Install Printers
window opens.

b. Select your printer with outdated printer drivers.

c. Select computers using outdated printer drivers.

d. For your Driver Package, select the newest driver package version. You see alerts that your
drivers will update.

e. Install your printers with your upgraded driver package.

When your installation completes, all your printer driver packages are consolidated on printers of the same
model in your environment.

TIP
You can also upgrade all your printers using the same driver package by replacing your
driver package. Go to Printers > Printers > Driver packages, select a driver package, and
click Replace driver package. Read Section 6.10, “Driver Packages” for more information.
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6.6.4.2. Be certain when installing new printers

Installing new printers on multiple computers with other printers already installed can cause unintended
effects. Installing a new print queue version updates all the print queues using that printer driver. Use the
Environment page to know which driver package version to use for installation.

NOTE
Whenever possible, use 1 printer driver provider and 1 driver package version for all printers
of the same printer family.

For example:

• All Zebra printers in your environment use Loftware version 10 printer drivers.

• All Sato printers in your environment use Loftware version 8 printer drivers.

1. Go to Control Center > Printers > Overview > Environment.

2. On your list, drag and drop the Printer manufacturer and Computer name column headers to group
by those columns.

3. Under Print queue driver version, look for computers running different driver package versions on
different computers for the same printers. You can:

• Install a new printer for both printers. Depending on which printer driver version you choose,
you also update other print queues on one or both computers.

• Run the Install Printers wizard twice for each computer. Select the driver version that is
already installed. No drivers update in this scenario.

NOTE
You can only install new printers with Loftware printer drivers. Installing new printers
doesn't affect printers using drivers from other providers.
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6.6.5. Provisioning Operations

Review all your centrally-managed printer and driver updates, installations, and removals, all in one place.

Provisioning Operations are tasks you assign from Control Center that execute on connected computers in
your system. Installing printers, updating drivers, or removing print queues creates a new entry in your log
of pending, ongoing, and completed Provisioning Operations in Control Center. Use your list of provisioning
operations to see the status of your operations, view scheduled operations, and review operations with
errors. Provisioning helps you maintain your centrally managed printing system and plan future updates.

NOTE
Provisioning operations do not appear in History. Provisioning operations remain on your
Provisioning Operations page for 30 days after creation, then they delete automatically.

How provisioning helps

Installing and updating drivers in enterprise environments can be difficult to coordinate and schedule. To
avoid shutting down production just to install updates, printer drivers are not always kept up to date on
every computer. A lack of coordination can result in you running different versions of the same driver on
different computers, leaving your printing process prone to downtime, errors, and printing inconsistencies
across your system.

With centralized provisioning operation management, you can immediately see what updates, installations,
and removals you have scheduled, the status of completed operations, and whether they were successful
or had errors. Use this information to better understand your daily operations in multiple locations and
schedule routine updates across your entire printing system.

Go to Control Center > Printers > Overview to see your most recent provisioning operations:

Click on Provisioning Operations to open your list page of all provisioning operations in your system:
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Your detailed list includes provisioning Operation name, Date created, Status (Finished or Error), and the number of Printers, Computers,
and Driver packages each operation affects.

NOTE
If your provisioning operation fails, you can see the cause listed in Control Center. if you
need more information, consult the log on your connected computer.

Click an Operation name to open the Operation page and see more information including Computer, Status,
and Details:

Toggle + and - next to individual computers to see Printers affected, Progress, whether the printer is Installed (Yes or No), and Details of
all executions of your selected operation.

Provisioning operations in Control Center help you see your centrally-managed updates and installations,
diagnose problems, and maintain your global printing system.
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6.7. Computers

Get real-time updates and make changes on every computer in your system from one place.

Use Computers in Control Center to see which printers are installed on which computers, check if specific
printers are installed, and manage Print queues installed on all your computers. Computers available
for centralized printer management include desktop and laptop computers, servers, and virtual machines
that can connect to printers and send printing instructions. Install printers you add to Control Center on
your computers with your uploaded printer driver packages to start centrally managing your label printing
system.

On computers you want to print from, install any NiceLabel desktop application and sign in to your
account. Signing in connects your computer to Control Center and makes it available for centralized Printer
Management.

NOTE
Print management features in Control Center only work if you install the latest NiceLabel
software on your computers.

• Go to Control Center > Printer Management > Computers to see your list of connected computers.
Click column headers to sort your list by column.

• Add your computers to printer Groups to make sure your printer operators with access to specific
groups have permissions to install and update printers on computers they need. To add computers
to groups, select your computers and click More > Set group. For more information, read Section 6.9,
“Groups”
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• To remove computers from your list of connected computers, select your computers and click More >
Remove computers.

NOTE
You can only remove offline computers. To remove a connected computer, first
disconnect it from Control Center, then remove it from this page.

• Click on computer names to view and update Computer Information and see a list of centrally-
managed Installed Printers for specific computers.

• Print queues: view queues statuses and pause, resume, clear, and delete print queues for your
printer.

Centrally managing your connected computers from Control Center helps you quickly install printers and
control your printing process.

6.7.1. Print queues

Print queues are an essential component of centrally managed printing. Print queues appear in your
Overview page, Printer Settings page, and Computers detail page.

A print queue is a virtual concept~a holding area for storing spooled print jobs while the printer is trying
to catch up. You don't actually send print jobs to printers, you send them to print queues until printers start
printing at print time. A print queue doesn't require a printer~ it continues to accept jobs while the printer is
offline (like while being repaired).
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• Jobs you send to printers actually go to print queues first.

• When your printers are printing jobs, print queues store additional spooled print jobs.

• Print queues are independent from printers and can continue to accept jobs even when printers are
offline.

• In Control Center, the Print queues page lists all your printers, but you can only manage queues for
your licensed printers.

• Performing actions on print queues for unlicensed printers uses a printer license seat for that printer.

• Deleting a print queue creates a provisioning operation.

6.8. Profiles

Create and update custom printing preferences for multiple printers in your system at once, from one
place.

A driver profile is a set of printing preferences linked to a specific printer driver. Putting printing preferences
in profiles allows many printers to share the same set of printing preferences without the need for
duplication.

Assign driver Profiles to your printers to apply the same printing preferences on multiple printers of the
same model without manual configuration. Profiles are sets of printing preferences for specific printer
models in Control Center. Centrally-managed Profiles save you time setting up, accessing, and updating
printing preferences for individual printers of the same model in your system.

NOTE
You can add centrally-managed printers of any manufacturer or model to your profiles, but
we recommend only using printer model-specific profiles. You can also use manufacturer-
specific printer profiles to manage generic settings like speed and darkness.

Open Control Center > Printers > Profiles to see your detailed list of profiles.

Working with Profiles

To add new profiles:
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1. Go to Printers > Profiles.

2. Click Add (on your top left). The Add New Driver Profile page opens.

3. Choose a new Profile name and Description.

4. Choose your Printer manufacturer from the drop-down menu.

NOTE
If you don't see your printer manufacturer, add the correct printer Section 6.10,
“Driver Packages” for your printer to Control Center.

5. Choose your Printer model from the drop-down menu.

6. Choose your Driver package from the drop-down menu. Printing Preferences appear for your
selected printer.

7. Choose shared Printing preferences for all printers assigned to your profile. Available printing
preferences depend on your printer model and manufacturer. For more information, read
Section 6.6.3, “Managing Printing Preferences”.

8. Click Save. Your new profile appears on your list on Printers > Profiles.

To update profiles:

1. Go to Printers > Profiles.

2. Click an existing profile name. The profile page opens.

3. Update your existing Profile Information and Printing preferences.

4. Click Save. Your updated profile appears on your list on Printers > Profiles.

To delete profiles:
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1. Go to Printers > Profiles.

2. Select existing profiles and click Delete. The Delete Driver Profiles window opens.

3. Click Delete. Your profile no longer appears on your list on Printers > Groups.

Adding or changing profiles to printers

1. Go to Control Center > Printers > Printers.

2. Select printers you want to add or change profiles.

3. Click More > Change settings profile.

4. Select your printer profile.

5. Click Save.

Creating profiles for specific models of your centrally-managed printers helps you save time configuring
and update multiple printers at once.
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Removing profiles from printers

1. Go to Control Center > Printers > Printers.

2. Select printers you want to remove profiles.

3. Click More > Change settings profile.

4. Click Clear profile settings.

5. Click Save.

6.9. Groups

Organize all the printers in your system into groups to control your entire printing system from one place.

Use groups to organize your computers and printers into logical structures that reflect the structure of your
printing environment or setup. Use groups to define access rights and give only certain users access to
your computers and printers.

Organize centrally managed printers in your system into groups and set printer group permissions by user
or by Access Role in Control Center. You can create groups and subgroups for all the printers in your global
system so you stay organized. Assign printer group permissions for your printer operators in Users to allow
them to change printing preferences for all the printers in specific subgroups.
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NOTE
You can also add Section 6.7, “Computers” to Groups so your Acces Roles with group
permissions can install printers.

Open Control Center > Printers > Groups to see your list of names and descriptions of groups you create.

Organize your printer groups and subgroups to reflect your IT environment. For example, you can group by physical location.

Working with groups

To add new groups:

1. Go to Printers > Groups.

2. Click Add (on your top left). The Add Group window opens.

3. Choose a new Group name and Description.

4. Click Add. Your new group appears on your list on Control Center > Printers > Groups.

To add new subgroups:

1. Go to Printers > Groups and select an existing group.

2. Click Add (on your top left). The Add Group window opens with your existing group as the Parent
group.

3. Choose a new Group name and Description.

4. Click Add. Your new subgroup appears on your list on Control Center > Printers > Groups.

To update groups and subgroups:

1. Go to Printers > Groups and select an existing group.

2. Click Edit (on your top left). The Edit Group window opens.

3. Choose a new Parent group, Group name, or Description.
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4. Click Save. Your updated group appears on your list on Control Center > Printers > Groups.

To delete groups:

1. Go to Printers > Groups.

2. Select your groups and click Delete. The Delete Group window opens.

3. Click Delete. Your group no longer appears on your list on Control Center > Printers > Groups.

Adding printers to groups

To add installed printers to your existing groups from your printer list:

1. Go to Control Center > Printers > Printers to see printers in your system.

2. Select printers to add to a group.

3. Click More to open the drop-down menu.

4. Click Set group. The Set Group window opens.

5. Select a group from the drop-down menu and click Set. Your group appears on your printer list on
Control Center > Printers > Printers.

To add installed printers to your existing groups or update group membership from printer pages:
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1. Go to Control Center > Printers > Printers, click a printer name to open the printer page.

2. Under Printer Information, choose a Group from the drop-down menu (Click X to remove your
printer from any group).

3. Click Save all (on your top right). Your group appears on your printer list on Control Center >
Printers > Printers.

Adding group permissions for Access Roles

Assigning printer management permissions by group gives your Operators (and other Access Roles you
customize) access to only the printers they're responsible for to keep your system more secure.

1. Go to Control Center > Users > Access Roles.

2. Click an Access Role name to edit. The Access Role page opens.

3. Under Permissions for this Role, click Printers.

4. Choose General and Default group permissions for your Access Role. These permissions apply to
all groups. To restrict access to only some groups or subgroups, unselect all general and default
permissions and add Custom Group Permissions for specific groups for your Access Role.

NOTE
Assign your Access Roles group permissions for only the subgroups they need
to access. Subgroups inherit permissions from parent groups, so assigning
permissions to a group also applies to permissions to all subgroups in that group.

5. To choose permissions for specific groups or subgroups, under Custom Group Permissions, select
a group to update.
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6. Click Customize. The Customize Permissions window opens.

7. Choose custom group permissions for your Access Role and click Customize. Your updated
permissions appear on your Custom Group Permissions list of groups.

NOTE
To remove access to groups for your Access Roles, under Custom Group Permissions,
remove all permissions.

Use Groups to map your printing facilities, give your users access to printers they manage, and maintain
your entire label printing system.

6.10. Driver Packages

Control all printer drivers and driver versions your printers use on all computers in your system.

Central driver management in Control Center helps you maintain a stable printing environment by ensuring
that all your printers use the same driver versions. Different driver versions produce different printing
results, so using the same driver version for all the printers of the same family in your system keeps your
printing consistent on all your printers. Centralized driver management keeps downtime to a minimum
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when you install or update printer drivers across the computers in your system. Printer drivers allow
computers and printers to communicate and relay hardware specifications, printing preferences, print
requests, and other printing instructions.

A driver package is a compressed (zipped) bundle of the all files you need (like .inf and .dll files) to install
printer drivers on Windows for a specific manufacturer. When you download your driver packages for free
from Loftware, you're downloading a bundle of all the drivers for all the supported printer models of that
specific manufacturer.

NOTE
Centralized printer management only works with Loftware printer drivers.

Go to Control Center > Printers > Driver Packages to see all the driver packages uploaded to Control
Center.

Click on driver package names to view and update driver package information, replace driver packages, and
see a list of printer models your driver package supports:

How centrally managed drivers help

Without Printer Management, updating printing preferences like print speed and darkness requires
physically going to each computer connected to your printer and opening driver settings. When your printer
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operators working directly with printers want to update preferences (like changing darkness from 11 to 15),
they need to physically or remotely access all the computers where the printers are installed. Because they
need system access to change settings on multiple computers, security problems result from granting the
additional access permissions required only to change printer settings.

With Printer Management, you can update printing preferences for all your installed printers instantly in
Control Center. When your printer operators want to update settings, they don't need access to computers
or any additional system permissions to change printing preferences. You can give printer operators
permission to edit printing preferences for specific printers, computers, driver packages, or printer profiles
in Control Center. When your printer operators log in to Control Center and update printing preferences for
their printers, the changes take place immediately and reduce printing downtime.

Adding driver packages

Before you can install printers on your computers from Control Center, download the correct Loftware
printer drivers for your printers from our driver downloads page.

NOTE
For access to all centralized Printer Management features, we recommend downloading
and installing Loftware version 10 printer drivers. Version 10 printer drivers fully support
printer provisioning and web-based centralized printing preferences in Control Center.

1. To add driver packages, click Add. The Add New Driver Package window opens.

2. Under File Information, click Select file and find your downloaded driver package .zip file.

3. Select your driver package file and click Open to upload your driver package. Your file begins
uploading to Control Center

4. Under Driver Package Information, type your Driver package name and any Notes about the driver
package.
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5. Click Save.

Your new driver packages appear on your list in Control Center > Printers > Driver Packages.

Replacing driver packages

Replace existing driver packages for your printers when you add updated driver packages to Control Center.
Replace your driver packages to maintain as few driver versions as possible in your system for consistent
printing outputs on all your printers. Minimize downtime and potential printing problems by replacing old
drivers for multiple printers at once and seeing how your replacement affects your printers and computers
before installation begins.

TIP
You can have multiple versions of the same printer driver installed in Control Center. In
some cases, users print to the same printer, but with different driver versions.

You can set preferred driver packages when you assign specific printers to new
workstations. On your Printer page click your printer and the SUMMARY window opens. In
the Printer Information section select your driver in the Preferred driver drop-down menu.

Using the same driver version (preferably the latest version) on all workstations helps you
to minimize errors caused by wrong printer settings.

If you select a non-preferred driver version, a warning message appears.

If your preferred Loftware drivers are version 10 or newer, you can update printing
preferences directly in Control Center. If you choose to use older preferred driver versions,
you may not be able to change your printing preferences directly in Control Center without
DEVMODE.
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To replace driver packages:

1. Click a driver package name on your list in Control Center > Printers > Driver Packages.

2. Under Version, click Replace driver package. The Replace Driver Package window opens.

3. Choose an updated driver package from the drop-down menu. Choosing a replacement driver
package displays more information.

4. Click Next to verify the effects of replacing your driver package. The Verify Effects tab opens with a
detailed list of effects.

5. Click Next to choose installation options. The Install Options tab opens.
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a. Review your settings and choose whether to allow your installation to restart printer
spoolers. Choosing Yes may affect current print jobs in your queue. If turned off, changes
take effect after your computer restarts.

6. Click Finish to replace your driver package.

Your driver package is replaced with an updated version for your printers and computers.

Removing driver packages

NOTE
Driver packages you remove from Control Center remain installed on your individual
computers.

To remove driver packages from Control Center:

1. Go to Printers > Driver Packages.

2. Select driver packages to remove.

3. Click Delete.

Your driver package no longer appears on your list in Control Center > Printers > Driver Packages.

Centrally managing your printer drivers in Control Center helps you install and update drivers, plan driver
updates to reduce downtime, quickly correct inconsistencies, and change printing preferences for your
entire system.

6.11. Licensed printers
In NiceLabel Control Center you can see all the licensed printers in your system and reserve or unreserve
printers from one place.
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NOTE
Licensed printers are printers that occupy printer seats. Printer seats are claimed
automatically when printing or manually by reserving printers.

Printers you use for printing labels appear on the Licensed Printers list in Control Center and take up
your printer seats. To see how many printers are on your license, view your License Information on your
Dashboard in Control Center. After 7 days of no printing, Control Center removes your unused printers from
the Licenced Printers list, and they no longer count towards your printer seats until you print from them
again. For more information, read Counting licensed printers.

NOTE
Printer seats are printer usage units. With each printing to a different physical or virtual
(XPS, PDF) printer, a printer takes one printer seat.

Go to Control Center > Printers > Licensed Printers to see your Licensed Printers:

Your detailed list of licensed printers.

• Click the column headings to sort your list by Printer, Location, Port, Last used (in days), and
Reserved status (Yes or No).

• Toggle + and - (on your left) to see more details for each licensed printer, including Computer, User,
and Printer queue name.

• To make sure specific printers are always available to print, select your printers and click Reserve
Printers. Reserved printers stay on your list of reserved printers even after 7 days of no activity.
By reserving printers, the print seats stay reserved until you click Unreserve Printers. For more
information, read Reserving license seats.
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• When a computer is printing, the Printer column shows the print queue name and printer model by
default. When 2 or more computers are printing to 1 printer, the Printer column shows the printer
name because there are multiple print queues.

• When you reserve printers from the Printers page, a new column appears on the Licensed Printers
page. If the printer hasn't yet been used to print, the Computer column stays empty. Changing printer
names on the Printers page doesn't change the printer name field on Licensed Printers.

Use Licensed Printer information to reserve your mission-critical printers and reduce printing delays by
controlling all the printers in your label printing system. For more information on printer licensing, read
Activating your license.

6.12. Reserving printers

NOTE
All NiceLabel products use printer-seat-based licensing. That means printer seats
determine how many printers you can print to at a time.

Printer seats are printer usage units. With each printing to a different physical or virtual
(XPS, PDF) printer, a printer takes one printer seat.

To avoid exceeding your printer seat limit, read how NiceLabel licensing works.

Your reserved printers are always ready for printing. Reserving your printers secures your limited printer
seats for printers essential to your operations and makes sure specific printers are always available to print.

IMPORTANT
If you don't reserve at least one printer, a warning shows on your screen.
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7. History
Control Center offers a detailed history log of all events in the printing system and a flexible sorting and
filtering system, which assists you in finding the events that you're interested in. The events can either be
displayed on a single list or split into the following categories:

• Printing. Events and details related to print jobs.

• Errors. NiceLabel applications printing errors.

• System. Audit log with all Control Center activities.

• Alerts. List of issued NiceLabel applications printing, Control Center, and licensing alerts. See also
Email Alerts topic.

• All Activities. Detailed print jobs events log.

To access your history logs, click the History tab in Control Center

WARNING
In time, the size of logged data can reach several Gigabytes which starts to affect the
performance of the Control Center. To avoid performance issues, you can archive your
History logs if you go to Administration > Storage (Archiving?). See the instructions in
Managing Storage and archiving History logs topic.

NOTE
Control Center shows timestamps in your local (server) time, but timestamps are stored in
the Control Center database in the UTC timezone.

7.1. Data Filtering and Columns
A default view to the collected data is one day of event history. You can quickly adjust the time frame if you
click Filters > Submitted. You can select predefined time intervals or define your custom time interval.
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After you define the preferred time interval, the page updates and shows the events from the defined
interval.

To make a precise selection of your print jobs, define a custom filter by clicking the items in Filters list.
You may create a filter on other parameters, such as printer names, workstation names, user names, label
names, and many more.

NOTE
You can remove filter items in all categories, except in Submitted, where you can only
change the default time frame.

You can also disable displaying the columns that are not important to you. Click the Columns button and
deselect the columns you want to remove. You can enable the columns back anytime.

7.2. Printing
The Printing page displays the list of printing events. Each event includes information about the print job
application (module), workstation, user, printer, and printing status.

To display detailed information about the selected printing event, label preview, and possible error, click the
row with the selected print job. Print History Details window opens.

Use Filters and Columns buttons to narrow down the search for your print jobs and customize displaying of
the Printing page. Filters help you when you are searching for a print job you want to reprint.

NOTE
In Print History Details window you can reprint your labels. When you press Reprint button,
a window with additional options opens. You can define which print jobs you want to print,
select some other printer to print your print jobs, and add your comments.
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NOTE
For more details about print job statuses, read the section Job Statuses.

Status. in the Label section specifies the last known status of the print job as reported
from the Loftware printer driver. To see these statuses, enable the option Detailed printing
control. To enable this option, open Desktop Designer and go to File > Options > Control
Center tab.

NOTE
Print History Details > Print Job section also displays Metadata if available. You can define
Metadata in a NiceLabel form or in Automation at advanced print options in Print Label
action.

You can download the Printing log as an Excel sheet if you click the Download button at the bottom of the
page.

Size of printing history log

Each print job creates a new printing history log in your Control Center database. Print history logs contain
Print job details (status, label name, print quantity, print time,...) and Label details (variable name, variable
type, and variable value) for each printed label.

When you print frequently, your Control Center database size might grow rapidly. Labels with more variables
and longer variable values create more extensive logs. Typically, each printed label creates a 1KB-2KB log.
Graphics don't affect the sizes of logs and Print job details create an insignificant amount of data.

To archive your printing history logs and free your database space, see the Archiving topic.
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7.3. Errors
The Errors page displays an overview of logged printing errors. Each error event includes information about
the print job application (module) computer, user, and printing status.

Use Filters and Columns to narrow down the search for your printing errors and customize your Errors page
display.

To display detailed information about the print job with error, click the row with the selected error event.
Print History Details window opens.

NOTE
For more details about print job statuses, read the section Job Statuses.

NOTE
Print History Details > Print Job section also displays Metadata if available. You can define
Metadata in a NiceLabel form or in Automation at advanced print options in Print Label
action.

You can download the Errors log as an Excel sheet if you click the Download button at the bottom of the
page.

7.4. System
System page displays a list of all operations, procedures, or events in your Control Center, for example:

• Audit types:

• Client authentication

• Document storage

• Versioning and Workflows
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• Global variables

• Event action:

• Successful login

• Workflow step changed

• Automatic revision conversion

• Check In

• Details:

• File path

• Workflow name

• User name

• Module

• Workstation

• User

• Submitted date nad time.

Use Filters and Columns to narrow down the search for your Control Center events and customize
displaying of the System page.

You can download the System data as an Excel sheet if you click the Download button at the bottom of the
page.

7.5. Alerts
Email Alerts feature automatically sends detailed information about errors in printing or in applications.
The Alerts page displays a list of all Email Alerts sent from your Control Center to users.

For a detailed description of creating and managing Email Alerts, see our dedicated topic.

If there are multiple identical label printing errors, Alerts page doesn't display alerts for each of these errors.
In case of repeating printing errors, you receive a new alert every 15 minutes.

NOTE
If there are multiple identical label printing errors, Alerts page doesn't display alerts for
each of these errors. In case of repeating printing errors, you receive a new alert every 15
minutes.

The 15-minute alert delay only happens if you are continuously printing identical label
files using the same printer. If you change the label file or printer, you receive an alert
immediately after your computer reports an error.
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Use Filters and Columns to narrow down the search for your alerts and customize displaying of the Alerts
page.

You can download the Alerts data as an Excel sheet if you click the Download button at the bottom of the
page.

7.6. All Activities
All Activities displays all printing activities, but successfully executed and with errors. Control Center logs
printing activities and details from all NiceLabel applications. In All Activities you can see also errors
caused by misconfigured NiceLabel solutions and configurations, for example if your labels don't print
because of invalid variable content or wrong printer name.

Records with error events are written in red.

TIP
In All Activities you can add your own log records with customized information and details
about your printed labels or errors.

Add Log Event action to your Automation configuration or Desktop Designer solution with
Information and Details data.

To display detailed information about the print job, click the row with the selected event. Print History
Details window opens.
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NOTE
For more details about print job statuses, read the section Job Statuses.

NOTE
Print History Details > Print Job section also displays Metadata if available. You can define
Metadata in a NiceLabel form or in Automation at advanced print options in Print Label
action.

Use Filters and Columns to narrow down the search for your printing activities and customize displaying of
the All Activities page.

You can download the All Activities data as an Excel sheet if you click the Download button at the bottom
of the page.
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7.7. Job Statuses

7.7.1. Print job statuses

Possible print job statuses are:

• Deleting: job has been deleted from the spooler.

• Deleted: spooling process has been interrupted because the print job has been manually deleted from
the print queue.

• Error: error condition on the printer - typical reason could be head opened on the printing device.

• Error - Printing: The error condition is due to a port conflict.

• Paused: this print job has been paused.

• Printed: print job has been successfully sent to the printing device.

• Printing: printer is processing the sent print job .

• Restarting: complete print job will be resent to the printing device.

• Queued: print job is in the waiting line in the spooler and will be sent to the printing device, when it has
finished processing the previous job.

• Start spooling: print job has started to be sent to the printing device.

• Spooling: print job is being sent to the print spooler.

• Spooled: print job has been created in the print spooler without errors.

• Spool failed: while print job has been sent to the printing device, an error has occurred during print or
the job was canceled.

7.7.2. Label job statuses

NOTE
You have to use printer driver in order to see label job status. If you do not use printer driver,
the final label status is "Spooled".

The possible label job statuses are:

• Preparing: data for label job is just being processed and will be sent into print spooler.

• Send failed: label job could not be sent to the printing device successfully. The printer has reported a
problem.

• Sent: label job has been successfully sent to the printing device.
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• Sending: label job is being sent to the printer.

• Spool failed: while print job has been sent to the printing device, an error has occurred during print or
the job was canceled.

• Spooled: label job has been created in the print spooler without errors.
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8. Analytics
Analytics in Control Center helps you monitor and analyze your entire label printing process, giving you
ways to understand what and how you print. In enterprise environments, Analytics helps you know:

Which users print which labels from which computers with which programs on which printers using which
materials.

You can quickly sort and find information you need with these data Filters and tabs:

• Labels—file names, amounts printed, printers used, dimensions, stock numbers.

• Printers—models, amounts printed, dimensions, stock numbers.

• Printer Groups—which groups, amounts printed, dimensions, stock numbers.

• Users—user names, amounts printed, printers used, dimensions, stock numbers.

• Computers/Applications—computers, modules (Automation, Control Center, Designer, Print, Printer
Driver, SDK, Web Printing), labels printed, printers used, dimensions, stock numbers.

• Materials—label dimensions, stock numbers, amounts printed, printers used.

Use Analytics to sort, monitor, and analyze your printing process in Control Center. Analytics helps you
organize and plan your printing tasks, improve your printing processes, and find ways to decrease your
printing costs.

Click the top of your bar graph to switch views between your Number of printed labels (1) and Number of errors (2). Scroll to zoom in and
out and see more data.

To use Analytics, click the Analytics tab in your Control Center.

NOTE
If your Analytics graphs and detailed lists are empty, or you experience other display errors,
try disabling your browser adblocker. For the best experience, we recommend disabling
your adblocker or whitelisting Control Center.
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8.1. Label Analytics
Know which labels print how often on which printers using which materials.

When you want to decrease labeling costs, use Analytics in Control Center to view and analyze which labels
you print the most so you can get the biggest savings with the smallest changes to your labels. You can
customize print date ranges and see specific label data with Filters.

To view and filter your label printing data, follow these steps:

1. Open Analytics in Control Center.

2. To sort your data by label file name, click the Labels tab (on your top left).
To sort your data by label dimensions, click the Materials tab (on your top left).
Analytics displays your bar graph and list of label printing data (toggle to display number of errors).

3. Scroll down to view your list of file names, numbers of printed labels, and numbers of errors.

• File names contain full paths of labels you print. If your labels are parts of solutions, Analytics
displays full solution paths and your label names.

• Number of printed labels shows how many labels you print on rolls. If you print your labels on
sheets of paper, Analytics displays how many pages you use (ex: 33 pages of labels).

• Number of errors shows how many errors occurred.

4. Toggle + and - (on your left)to view detailed lists for specific computers.

• Click on a column to sort column data.

• Sort by labels, label dimensions (width x height)/stock number, labels printed, or errors.

• Analytics displays your label information in the following ways:

Display Example: Meaning:

10 x 5 cm Dimensions in cm

3" x 6" Dimensions in inches

30 x 22 mm Dimensions in mm

40 x ? Width is constant, but label height is variable. Your label
length depends on the amount of data in your label.

10 x 7 cm / A4 When you print on sheets of paper, Analytics shows
label dimensions and paper size.

30 x 20 mm / A4 - STOCK9i9i Analytics shows your label dimensions, paper size, and
stock number.

5. Analytics displays printing data from today on your graph and list by default. To see data from
another print date range, go to Filters > Print date (on your right).

• Use the drop-down menu to select pre-defined date ranges.
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• Customize your print date range by selecting Custom and choosing a date range with From
and To.

• Click Add to apply your filter to your graph.

6. To see data from specific users, go to Filters > Label name or Label dimension filters (on your
right).

• Click active filters above your graph to open a drop-down menu and select/deselect more
labels. Click Save to apply your updates.

7. Apply multiple filters at once to fine-tune your data view and find exactly what data you need.

• For more information, see Section 8.6, “Analytics Filters”.

8. Click Download (on your bottom right) to export your data.

• Analytics includes your applied data filters and only exports data you see.

• Your data downloads as an .xml file you can open in Microsoft Excel.

Use Analytics to view and analyze label printing data during print date ranges you select. Use this data to
optimize your printing processes and find ways to decrease your costs.

8.2. Printer Analytics
Know which printers print which labels and how often.

When your printing workloads are not evenly distributed between your printers, use Analytics in Control
Center to view and analyze which printers print the most labels so you can more efficiently distribute your
workloads. You can customize print date ranges and see specific printer data with Filters.

To view and filter your printer workloads, follow these steps:

1. Open Analytics in Control Center.

2. Click the Printers tab (on your left).
Analytics displays your bar graph and list of printer data (toggle to display number of errors).

3. Scroll down to view your list of printers, labels they print, and errors.

• Number of printed labels shows how many labels you print on rolls. If you print your labels on
sheets of paper, Analytics displays how many pages you use (ex: 33 pages of labels).

• Number of errors shows how many errors occurred.

4. Toggle + and - (on your left) to view detailed lists for specific computers.

• Click on a column to sort column data.

• Sort by label dimensions (width x height)/stock number, or labels printed.

• Analytics displays your label information in the following ways:
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Display Example: Meaning:

10 x 5 cm Dimensions in cm

3" x 6" Dimensions in inches

30 x 22 mm Dimensions in mm

40 x ? Width is constant, but label height is variable. Your label
length depends on the amount of data in your label

10 x 7 cm / A4 When you print on sheets of paper, Analytics shows
label dimensions and paper size

30 x 20 mm / A4 - STOCK9i9i Analytics shows your label dimensions, paper size, and
stock number

5. Analytics displays printing data from today on your graph and list by default. To see data from
another print date range, go to Filters > Print date (on your right).

• Customize your print date range by selecting Custom and choosing a date range with From
and To.

• Click Add to apply your filter to your graph.

6. To see data from specific printers, go to Filters > Printer (on your right).

• Click the active Printer filter (above your graph) to open a drop-down menu and select/
deselect more users. Click Save to apply your updates.

7. Apply multiple filters at once to fine-tune your data view and find exactly what data you need.

• For more information, see Section 8.6, “Analytics Filters”.

8. Click Download (on your bottom right) to export your data.

• Analytics includes your applied data filters and only exports data you see.

• Your data downloads as an .xml file you can open in Microsoft Excel.

Use Analytics to view and analyze printer workloads during print date ranges you select. Use this data to
optimize and redistribute uneven printing workloads.

8.3. Printer Group Analytics
Know which printer groups print which labels and how often.

When your printing workloads are not evenly distributed between your printer groups, use Analytics in
Control Center to view and analyze which printer groups print the most labels so you can more efficiently
distribute your workloads. You can customize print date ranges and see specific printer group data with
Filters.

To view and filter your printer group workloads, follow these steps:
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1. Open Analytics in Control Center.

2. Click the Printer Groups tab (on your top left).
Analytics displays your bar graph and list of printer group data (toggle to display number of errors).

• Number of printed labels shows how many labels you print on rolls. If you print your labels on
sheets of paper, Analytics displays how many pages you use (ex: 33 pages of labels).

• Number of errors shows how many errors occurred.

3. Scroll down to view your list of printer groups and labels they print.

4. Toggle + and - (on your left) to view detailed lists for specific computers.

• Click on a column to sort column data.

• Sort by label dimensions (width x height)/stock number, labels printed, or errors.

• Analytics displays your label information in the following ways:

Display Example: Meaning:

10 x 5 cm Dimensions in cm

3" x 6" Dimensions in inches

30 x 22 mm Dimensions in mm

40 x ? Width is constant, but label height is variable. Your label
length depends on the amount of data in your label

10 x 7 cm / A4 When you print on sheets of paper, Analytics shows
label dimensions and paper size

30 x 20 mm / A4 - STOCK9i9i Analytics shows your label dimensions, paper size, and
stock number

5. Analytics displays printing data from today on your graph and list by default. To see data from
another print date range, go to Filters > Print date (on your right).

• Use the drop-down menu to select pre-defined date ranges.

• Customize your print date range by selecting Custom and choosing a date range with From
and To.

• Click Add to apply your filter to your graph.

6. To see data from specific printer groups, use the Printer group filter (on your right).

• Click the active filter (above your graph) to open a drop-down menu and select/deselect more
Printer groups. Click Save to apply your updates.

7. Apply multiple filters at once to fine-tune your data view and find exactly what data you need.

• For more information, see Section 8.6, “Analytics Filters”.

8. Click Download (on your bottom right) to export your data.

• Analytics includes your applied data filters and only exports data you see.
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• Your data downloads as an .xml file you can open in Microsoft Excel.

Use Analytics to view and analyze printer group workloads during print date ranges you select. Use this data
to optimize and redistribute uneven printing workloads.

8.4. User Analytics
Know which users print which labels on which printers and how often.

When your printing workloads are not evenly distributed between your users, use Analytics in Control
Center to view and analyze which of your users print the most labels so you can more efficiently distribute
your user workloads. You can customize print date ranges and see specific user data with Filters.

To view and filter your user printing workloads, follow these steps:

1. Open Analytics in Control Center.

2. Click the Users tab (on your top left).
Analytics displays your bar graph and list of user data (toggle to display number of errors).

3. Scroll down to view your list of users, labels they print, and errors.

a. Number of printed labels shows how many labels you print on rolls. If you print your labels on
sheets of paper, Analytics displays how many pages you use (ex: 33 pages of labels).

b. Number of errors shows how many errors occurred.

4. Toggle + and - (on your left) to view detailed lists for specific users.

• Click on a column to sort column data.

• Sort by printers, label dimensions (width x height)/stock number, labels printed, or errors.

• Analytics displays your label information in the following ways:

Display Example: Meaning:

10 x 5 cm Dimensions in cm

3" x 6" Dimensions in inches

30 x 22 mm Dimensions in mm

40 x ? Width is constant, but label height is variable. Your label
length depends on the amount of data in your label

10 x 7 cm / A4 When you print on sheets of paper, Analytics shows
label dimensions and paper size

30 x 20 mm / A4 - STOCK9i9i Analytics shows your label dimensions, paper size, and
stock number

5. Analytics displays printing data from today on your graph and list by default. To see data from
another print date range, go to Filters > Print date (on your right).
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• Use the drop-down menu to select pre-defined date ranges.

• Customize your print date range by selecting Custom and choosing a date range with From
and To.

• Click Add to apply your filter to your graph.

6. To see data from specific users, go to Filters > User (on your right).

• Click the active User filter (above your graph) to open a drop-down menu and select/deselect
more users. Click Save to apply your updates.

7. Apply multiple filters at once to fine-tune your data view and find exactly what data you need.

• For more information, see Section 8.6, “Analytics Filters”.

8. Click Download (on your bottom right) to export your data.

• Analytics includes your applied data filters and only exports data you see.

• Your data downloads as an .xml file you can open in Microsoft Excel.

Use Analytics to view and analyze user printing workloads during print date ranges you select. Use this data
to optimize and redistribute uneven printing workloads.

8.5. Computer Analytics
Know which computers and which programs print which labels on which printers and how often.

When your printing workloads are not evenly distributed between your computers, use Analytics in Control
Center to view and analyze which of your computers print the most labels so you can more efficiently
distribute your workloads. You can customize print date ranges and see specific computer and program
module data with Filters.

To view and filter your computer/module printing workloads, follow these steps:

1. Open Analytics in Control Center.

2. Click the Computers/Applications tab (on your top left).
Analytics displays your bar graph and list of computer and application data (toggle to display
number of errors).

3. Scroll down to view your list of computers, modules, amounts of labels printed, and errors.

• Computers are computers you use to print.

• Modules are programs you use to print (Automation, Control Center, Designer, Print, Printer
Driver, SDK, Web Printing).

• Number of printed labels shows how many labels you print on rolls. If you print your labels on
sheets of paper, Analytics displays how many pages you use (ex: 33 pages of labels).

• Number of errors shows how many errors occurred.
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4. Toggle + and - (on your left) to view detailed lists for specific computers.

• Select columns to sort or drag/drop column headers to group by column data.

• Sort by printers, label dimensions (width x height)/stock number, labels printed, or errors.

• Analytics displays your label information in the following ways:

Display Example: Meaning:

10 x 5 cm Dimensions in cm

3" x 6" Dimensions in inches

30 x 22 mm Dimensions in mm

40 x ? Width is constant, but label height is variable. Your label
length depends on the amount of data in your label

10 x 7 cm / A4 When you print on sheets of paper, Analytics shows
label dimensions and paper size.

30 x 20 mm / A4 - STOCK9i9i Analytics shows your label dimentions, paper size, and
stock number.

5. Analytics displays printing data from today on your graph and list by default. To see data from
another print date range, go to Filters > Print date (on your right).

• Use the drop-down menu to select pre-defined date ranges.

• Customize your print date range by selecting Custom and choosing a date range with From
and To.

• Click Add to apply your filter to your graph.

6. To see data from specific computers or modules, use the Computer or Module filters.

• Use the drop-down menu to select/deselect specific computers or modules.

7. Apply multiple filters at once to fine-tune your data view and find exactly what data you need.

• For more information, see Section 8.6, “Analytics Filters”.

8. Click Download (on your bottom right) to export your data.

• Analytics includes your applied data filters and only exports data you see.

• Your data downloads as an .xml file you can open in Microsoft Excel.

Use Analytics to view and analyze computer printing workloads during print date ranges you select. Use this
data to optimize and redistribute uneven printing workloads.

8.6. Analytics Filters
Use Analytics filters in Control Center to understand your label printing processes. Apply multiple filters
at once to fine-tune your data view and find exactly the data you need for analysis, investigation, and
optimization.
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To apply multiple Analytics filters to your data, follow these steps:

1. Open Analytics in Control Center.
Analytics displays your bar graph and list of label printing data.

2. To filter data from specific items, use Filters (on your right). Select a filter and click Add to apply.

• You can apply multiple filters at once. Filters you apply appear above your bar graph.

• Use the filter drop-down menus to select/deselect specific items. For Label name and
Metadata filters, you can narrow your results to:

• Contains

• Does not contain

• Equals

• Does not equal

• Starts with

• Ends with

• You can select single or multiple items for each filter. Click your applied filter above your bar
graph and use the dropdown menu to add more items to your filter. Click Save to update your
filter and apply changes on your bar graph.

3. Choose from the following filters:

• Print date

• Printer

• Printer group

• Label name

• Label dimension

• User

• Computer

• Module

• Metadata
Metadata is extra information about labels you print, stored in databases with print jobs.
Metadata you assign does not appear on your labels, but you can use it for sorting, filtering,
and other functions.
Filter your data using custom metadata tags you create for jobs in Automation. Metadata filter
tags you type in Analytics are case sensitive and must exactly match your created tags to
filter correctly.
Examples of metadata include:

• Printer names
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• User/system generated values

• Data sources

• Lot numbers

Example

You define lot numbers for your labels in Automation (LotNumber=444, 445, 446, etc...). With
Analytics in Control Center, you filter your data with the metadata tag "LotNumber=444" to
analyze printing data for only lot number 444.

The metadata filter helps you analyze your print process for specific metadata tags you
choose.
For more information on creating and applying metadata in Automation, see the Print Label
action description.

4. Analytics displays printing data from today on your graph and list by default. To see data from
another print date range, go to Filters > Print date (on your right).

• Use the drop-down menu to select pre-defined date ranges.

• Customize your print date range by selecting Custom and choosing a date range with From
and To.

• Click Add to apply your filter to your graph.

5. With your filters applied, you can view your filtered data by selecting tabs (on your left).

• View filtered data on labels, printers, printer groups, users, computers/applications, or
materials.

6. To remove filters and return to your default data view, click the X on active filters above your graph.

Use Analytics to apply multiple filters to your printing data during date ranges you select. Use this data to
investigate, analyze, and optimize your printing processes.

8.7. Printing Optimization with Analytics
Compare stated label needs with actual usage data to find savings and optimize production.

Use Analytics in Control Center to see production data and investigate efficiency. Compare how many
labels you need with how many labels you print to analyze your label usage and losses, improve your
printing processes, and find ways to decrease your printing costs.

Example

You produce 1000 product units per month. For each unit produced, you need 1 label. This means your label
need is 1000 labels per month (1000 units x 1 label per unit).
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Now, use Analytics to see your usage data:

1. Open Analytics in Control Center.

2. Click the Labels tab (on your top left).

3. Use Filters > Print date (on your right) to see data from last month.

Analytics displays your bar graph and detailed list of user printing data.

From your graph, you see you printed 1100 labels last month, 100 more than you need.

Now you can investigate this difference between your label need and your usage data. Ask why you
print more labels than you need and use the answers to find and decrease waste, errors, misprints, and
malfeasance.

You can now use Analytics to view and analyze your usage data during print date ranges you select. Use
this data to investigate, optimize production, and find ways to save by decreasing printing costs.
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9. Users
Control Center also serves as a centralized user management tool. In Control Center you define how your
users access and work within your Label Management System. Assign Access Roles and set different
Permissions to make your labeling environment secure and easy to use.

To start managing your users, first, define your authentication method for your users. Your authentication
method depends on the product and edition you purchased:

• Label Management System:

• Authentication

• Application Users

You can invite your internal or external users to your Control Center.

Your second step is to manage your user privileges:

• Add your users or user groups as members of predefined Access Roles or create your own unique
access roles.

NOTE
Every Control Center user must be a member of at least one Access Role.

• Set your Role Permissions for your access roles to match your labeling needs.

You can control what your users do at both broad and granular levels.

TIP
Use Access Roles and Role Permissions to limit access to your:

• Files and folders stored in your Documents.

• Shared Applications for printing.

Different Access Roles and Permissions for different needs

In order to properly set up your NiceLabel label printing system your IT administrators need all permissions
enabled. The Administrator role is an Access Role with all Permissions enabled and is automatically
assigned to the user who activates Label Management System account.

Your printing operators have different needs, their work is limited to running printing Applications and
printing labels. To prevent mistakes and improve efficiency the best-suited access role, in this case, is the
Operator Access Role.
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9.1. Authentication
Authentication increases your Control Center security and allows you to assign users and user groups to
Access Roles.

Your Authentication Method enables only authorized users to log in to your Control Center and other Label
Management System modules. With an authentication method enabled, Control Center recognizes your
users and corresponding permissions.

NOTE
If you lose a stable connection with Control Center, a warning appears on your screen.
You enter a grace period, during which you can still work offline, but you must sign in and
reconnect your software before your grace period ends.

If you change your username and password, you have to reconnect your software before
your grace period ends.

Control Center administrators can set Access Roles for different users or groups of users. Each role has a
different set of permissions.

WARNING
To update your authentication method, at least one of your users must be a member of the
Administrator Access Role.

To update your Authentication Method:

1. Go to Administration > Authentication.

2. Select your Authentication method.

• As Windows AD users (recommended): Users are defined in your Active Directory. Your
server with Control Center must be a member of the same domain or you must establish a
domain trust relationship between your two domains.
Your users get access when you add their Windows AD to an Access Role in Control Center.
Your users become Windows users and don't need to enter credentials to log in to Label
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Management System Control Center. Their Windows credentials are sent directly to your
Control Center. Control Center also recognizes your Windows user groups.

NOTE
You can still add application users, but they can only run your shared
Applications.

NOTE

NiceLabel supports both LDAP and LDAPS (LDAP over SSL) connection
protocols.

LDAPS communication is encrypted and secure while LDAP transmits
communications in clear text.

Because of the potential for attacks and misuse of insecure LDAP
connections, Microsoft recommends using LDAPS with Active Directory
domain controllers when possible.

If your system cannot establish an LDAPS connection, you can use an LDAP
fallback connection.

• As application users: Users need to enter credentials (user name and password). Users
get access when they are added as application users in Control Center with corresponding
Access Roles.

NOTE
The default NiceLabel administrator password is NICE.

NOTE
You can define password settings for your application users.

See the details about the password settings in a topic about application users.

• Without authentication: Users don't need to enter credentials when they log in to Control
Center. They are not authenticated in any way, everyone in your network can access your
Label Management System and has all user privileges (Role Permissions).
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All users have access permissions from the Roles Off Access Role. By default, all Roles Off
Access Role users have administrative privileges.

IMPORTANT
By default, your Control Center authentication method is set to Without
authentication.

Consider possible security risks when you choose not to use authentication.

3. Click Save.

Your Authentication Method is updated. If you use authentication, you can now add users to Access Roles
and assign permissions.

9.2. Application Users
When inviting your organization members to the Label Management System, you must first define them as
users. The Users page allows you to centrally manage your users - you can add and group your Application
and Windows AD users, assign them privileges, and share Applications with them.

9.2.1. Adding Users

To add new web application user:

1. Go to Users > Users

2. Click Add User. First Select Windows AD user or Application user.
Under Settings, type in the required user information. If you selected Application user, define
username/password using which the application users logs in to your Control Center.

NOTE
If you defined additional password settings, the users must follow your password
complexity rules. These can include character types, number of characters, etc.

3. If you selected Application user, you can add your user to one or more of your application groups
under Application Groups.

NOTE
Before you can add your users to your Application Groups, first create your groups
as described in the Groups topic.

4. Under Applications, you can immediately start sharing your label templates or Applications from
your Control Center with your users.
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5. Under Access Roles, you can assign appropriate Access Roles to your users. Access Roles allow
you to control the User Privileges in your Control Center.

a. Click Add. The Add Access Roles dialog opens. Select the role(s) for your guest user.

b. Click OK.

NOTE
To see the granted privileges for each access role, go to Users > Access Roles >
click on the role. You can view granted permissions for this particular Access Role
under Permissions for this Role.

6. By default, the users' status is set to Active. Keep the status active to allow your user to log into
your Control Center.

7. Click Save.

Your invited Application users can now log in to your Control Center with the username and the password
you provided.

9.2.2. Access Roles

The Users page allows you to assign Access Roles to your added users. This is how you define the level of
privileges your newly added user has in Control Center. Read more about the Access Roles and the related
User Privileges in the section Managing User Privileges.

To assign Access Roles to your application user:

1. Go to Users > Users

2. Click on the user from the list. The user configuration page opens.

3. Under Access Roles click Add.

4. The Add Roles dialog opens. The available Access Roles are listed. Assign your user the
appropriate role(s).

5. Click OK.
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6. Click Save.

Your user is now a member of the selected Access Role with all the corresponding User Privileges.

9.2.3. Password Settings

If your company does not use the Active Directory, you can still enable authentication for your Control
Center. In this case, your authentication method is called "As application users" method. This application
authentication method allows you to define and manage your Control Center users within the Control
Center. These users become application users.

NOTE
In contrast to Windows authentication, the user who has the Administrator Access Role
defines the username and password for each individual application user.

To open and manage the password settings for your application users:

1. Go to Users > Users and click Password settings.

2. Define Password Character Settings:

• Minimal number of characters allows you to limit your users to create passwords longer than
"x" characters. Longer passwords are more secure.

• Uppercase, lowercase, letters and numbers - when enabled, your users must create
passwords using a combination of lower and upper case letters, and numbers. This raises
password complexity and makes the passwords harder to crack.

• Special characters - when enabled, your users must create passwords that contain special
characters. Special characters add to password complexity and make the passwords harder
to crack.

• Username cannot be part of the password - enable to make the passwords even more secure.
This prevents the users from setting their user names as part of the password.

3. Under Password Validity, you can optionally set the number of days the passwords remain valid.
After the defined number of days, users will be prompted to enter a new password. If they do not
change their passwords, the administrator must change the expired passwords to make them valid
again.

4. Under Password History, you can define the number of preceding passwords that your users cannot
use for logging into the Control Center. Use this option to prevent the users from reusing their
passwords after they become invalid.

5. Account Failed Log-In Attempts Suspension allows you to set the number of failed login attempts
before your Control Center automatically suspends the account. After suspending the user account,
the administrator must reactivate that account to make it available again.
To reactivate the account, go to User Management > Application Users > select your user > toggle
Status to Active.
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6. Account Inactivity Suspension sets the number of days of account inactivity before an account is
suspended.
To reactivate the account, go to User Management > Application Users > select your user > toggle
Status to Active.

7. Click Save.

With defined and enforced passwords you improve the level of your Control Center security.

9.3. Groups
Once you define your Users, it is a good idea to group your users. Groups help you organize your users
based on the department, role, or any other organizational group they are working for. Grouping user makes
it easier for you to assign privileges, and to share your Applications with multiple users at once.

NOTE
Application Users and Application Groups refer to users you define in NiceLabel.
Application users and groups are different than users and groups you define within your
Windows domain or Active Directory. You can use Application users and groups if your
environment is configured without Windows Active Directory.

9.3.1. Creating Groups

By creating groups, you can control which groups of users can access Web Applications you create in
Control Center.

To create a new group:

1. Open Control Center.

2. Go to Users > Groups.
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3. Click Add. The Create New Group window opens.

4. Based on your Group Type additional selections and settings open below.

5. Give your new group a Name or select AD group. Enter also a description and email address.
By default, the Application Group's status is set to Active.

6. If you selected Application Group, add Application Users to your group.

7. Add Access Roles to your group or skip this step and add them later.

NOTE
If you skip the Access Roles setting, users in this group will have administrator
rights.

8. Add Web Applications that users in this group will run.

9. Click Save.

Your new Group is ready and listed. Click group names to change or update your group data.

NOTE
When you remove your Active Directory Group from Groups in Control Center, Windows
AD group remains in your system, but all access rights and web applications rights are
removed from Control Center.

When you remove your Application Group from Groups, Control Center removes the
application group, access rights, and application rights.

9.3.2. Adding Application Users to Application Groups

You can add a single Application User to multiple Application Groups.

NOTE
Before you add your users to your groups, you must first add them to Section 9.2,
“Application Users”.
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To add Application Users to your group:

1. Go to Users > Users.

2. Click on a user name from your list. The user configuration page opens.

3. Under Application Groups, click Add.

4. The Add Application Groups dialog opens. Select a group or groups from your list.

5. Click OK. Your user now belongs to your selected group.

6. Click Save.

Your Application User is now Added to your Application Group and has access to Web Applications in your
group.

9.4. Access Roles
Using Access Roles helps you keep your entire labeling system secure. You can choose exactly what the
members of your Access Roles can do and see in Control Center and other NiceLabel modules within Label
Management System products.

Use the Users > Access Roles page in Control Center to set User Privileges for your labeling system
according to your own specific security policies. Access Roles allow you to assign different sets of
privileges to Control Center users.

NOTE
Before you can set user permissions, you must first enable authentication in your Label
Management SystemControl Center.

After you enable authentication, log in to Control Center as an administrator to access the
Access Roles page.

Control Center includes default access roles with well-balanced permission sets:

NOTE
These default Access Roles have preset ranges of privileges. You can manually change the
default permissions for each role except for the Administrator role.

• Administration: All permissions granted. Members in this role have full Control Center privileges.
Administrators can edit default roles, customize roles, and assign roles to users or groups.

• Approver: Allows role members to review, approve, or reject labels or solutions in Document Storage.
Approvers send documents to production.
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• Approver (second level): Allows role members to review, approve, or reject documents on the second
document approval step. Approvers send documents to production.

• Author: Allows role members to create or edit label templates and solutions. Members in this role can
edit labels and forms, and have control over label production.

• Operator: Allows role members to print labels and run solutions without editing. Members in this role
have read-only access to Document Storage and cannot change any label templates or application
configurations.

• Service Provider: Allows your service provider to access your account for support, setup, and
administration. This role has no members by default.

• Roles off: This role is automatically assigned to all Control Center users after you set your
Authentication method to Without authentication. By default, this role has all permissions granted.

Example

John needs full access to Documents storage to upload printing solutions and make them available for
production. Set John's Access Role to Author.

Annie needs access to the Reports page to prepare reports on printing consumables. You can assign Annie
to any default Access Role.

Charlie is a printer operator. He only runs solution files in runtime mode and prints labels. Set Charlie's
Access Role to Operator.

Martha is an account administrator. She needs access to all administrative features. Martha belongs to the
Administrator Access Role.

To learn how to edit default Access Roles or add new Access Roles, read Setting up Access Roles.

9.4.1. Multiple Access Role membership

If your users or user groups are members of multiple Access Roles, their overall security access sums up
privileges of all access roles.

When your users are members of two Access Roles, Control Center grants them privileges from their
highest Access Role and overrides privileges denied in other roles.

Multiple Access Role membership

Charlie is a member of Operator and Author Access Roles. His Operator role grants him read-only access to
files stored in Documents, but his Author role grants him full access to Documents. In this case, Charlie has
full access to Documents.

169



9.4.2. Creating Access Roles

You can set up Access Roles for users in Control Center in two ways. You can edit default Access Roles, or
create your own custom Access Roles from scratch. You can also duplicate the existing Access Role and
then edit the copy.

• Customize default Access Roles to comply with specific policies or procedures.

• You can keep default roles, use additional customized roles for special use cases, or add new Access
Roles.

NOTE
You can delete your customized Access Roles, but you cannot delete the default Access
Roles.

When you delete your customized Access Roles, role members lose their permissions
accordingly.

1. To open Access Roles, go to Users > Access roles.

2. You have three options:

• To edit a default Access Role, click the role you want to edit.

WARNING
Some default or user-defined access roles have enabled the option Update
files and folders. This might cause the printing of unpublished (draft)
revisions of your labels. This functionality serves testing environments so
we would suggest disabling the option Update files and folders in your
production environment.

You can disable this option if you scroll to Permissions for this rule section
and go to the DOCUMENTS tab > Default Document Permissions > Storage.

• To set up a new Access Role, click Add.

• To copy an existing Access Role, select the role, then click Duplicate.

3. Control Center opens Create New Access Role configuration page for editing.

a. In Settings, type the role name and description. Make these easy to differentiate from other
roles. For default Access Roles, you can edit the role description already there.

b. Set the role Status. Toggle Active to make the role available immediately. Toggle
Suspended to make the role unavailable.
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NOTE
Default Access Roles are always active. You can only change the Status of
new roles you create manually.

c. Set Permissions for this Role. Define which tasks the members of this Access Role can
perform. To learn more about setting permissions, read Setting role permissions.

d. In Users in this Role click Add to add individual users or user groups to your access role. A
new pop-up window opens.

• Application users lists all existing users who authenticate themselves using
application authentication.

• Application groups lists all existing groups of users who authenticate themselves
using application authentication.

• Windows users lists all users that are defined in your company's Active Directory.

• Windows groups lists all groups that are defined in your company's Active Directory.

4. Click Save.

Your Access Role is configured and ready to use.

NOTE
You can also create an Excel table with a report of all Control Center users and their Access
Roles In the Report of Users and Access Roles window click Create report.

9.4.3. Access Role Permissions

Setting Permissions for your Access Roles helps you keep your entire labeling system secure. You
can choose exactly what Access Role members can do and see in Control Center and other NiceLabel
programs.

NOTE
NiceLabel recommends using default Access Roles due to their well-balanced Permission
sets. Before you configure Permissions, consider your security policies and set
Permissions for each Access Role carefully.

For security, your users in different Access Roles need different levels of access to files, folders, and
actions when they use Control Center. NiceLabel groups common Permissions levels into default Access
Roles. Administrators can customize or create new Access Roles. Use the Permissions for this role section
in Access Roles to control which actions or settings are available to members of each Access Role.

To set Access Role Permissions, follow these steps:
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1. Log in to Control Center as an Administrator.

2. Go to Users > Access Roles.

3. Add a new Access Role or click on an existing Access Role from the list.
Create New Access Role

4. Set your Permissions.
The Permissions for this role section includes multiple tabs with lists and detailed descriptions of
available Permissions.

• To grant specific Permissions for this role, select your checkboxes.

• To disable specific Permissions for this role, clear your checkboxes.

NOTE
Disabling Permissions also makes them invisible to your Access Role
members.

• Use the General tab to set your global Role Permissions for your NiceLabel modules and
decide what users in this role can do in your labeling system. For example:

• Run NiceLabel programs:

• Desktop Designer

• Print

• Automation

• Edit documents

• Print labels

• Run forms

• Edit global variables

• Edit options

• Upgrade and deactivate licenses
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• Use the remaining tabs to set Role Permissions that are specific for Control Center. These
Permissions apply when your users log in to Control Center. The following Permissions tabs
correspond to pages in Control Center:

• Overview: Set access to the overview page in Control Center .

• Documents: Set general, default, and custom Permissions for Documents storage:
archiving/restoring, purging, setting workflows, etc.

NOTE
To learn more about file access control options, read File Access
Control.

• Applications: Set Permissions for Applications and Cloud Integrations management.

NOTE
You can also enable running NiceLabel Automation Manager.

• Printers: Set Permissions for print queue viewing and management, printer group
configuration, reservations, and cloud printers.
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WARNING
By default, all user rights in Printers are disabled. This can prevent all
users in all groups printing to shared printers. To avoid such situation:

• Make sure that NiceLabel Proxy Service 10 on client computers
runs under an account with administrative privileges. Don't use
Local System account.
Apply this step to all users that print to shared printers.

or

• Enable the two options as seen in the screenshot below:

• History and Analytics: Set Permissions for viewing errors, alerts, print job logs, label
reprinting, viewing data, and system audit logs.

• User Management: Enables your user to manage your authentication settings, Access
Roles, Application users and groups, and Application user password settings.

• Administration: Set multiple administrative permissions for Control Center Access Role
users.

5. Click Save to apply your permissions.

Your custom Access Role Permissions are saved and applied in Control Center and other NiceLabel
programs.
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9.4.4. Access Roles

The Users page allows you to assign Access Roles to your added users. This is how you define the level of
privileges your newly added user has in Control Center. Read more about the Access Roles and the related
User Privileges in the section Managing User Privileges.

To assign Access Roles to your application user:

1. Go to Users > Users

2. Click on the user from the list. The user configuration page opens.

3. Under Access Roles click Add.

4. The Add Roles dialog opens. The available Access Roles are listed. Assign your user the
appropriate role(s).

5. Click OK.

6. Click Save.

Your user is now a member of the selected Access Role with all the corresponding User Privileges.
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10. Administration
Go to Control Center > Administration to see your Product Information (Label Management System) and
update your Control Center settings from one place.

Label Management System Product Information with your Licence Details (1).

Open additional pages where you can enable features and update settings for Control Center:

NOTE
To make sure you see all Administration options, sign in as an Administrator.

• Authentication

• Storage

• Versioning and Workflows

• Database Replacements

• Global Variables

• Email Alerts

• Synchronization

• Archiving

Control Center Administrators can centrally manage settings and get information all from one place in
Administration.

10.1. Storage and Archiving
Your Control Center data includes your documents and printing history logs. All the data is stored in your
Control Center SQL database.
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You store your label files, solutions, graphics, and other files in the Documents storage. Control Center
generates History logs automatically and logs data size depends on the frequency of your printing
activities.

Archiving

In time, the size of stored data can reach several Gigabytes, which may affect the performance of Control
Center. To avoid performance issues, you can archive your History logs if you go to Administration >
Archiving.

• To enable periodical archiving, select the option Perform scheduled cleanups, then define Cleanup
Configuration settings.

• You can periodically perform cleanup of your Control Center SQL database by deleting the old content
or arriving the old content to your local Access database.

• With Organize archive data options you can create a new archive file for each cleanup or ad data to
the same file.

Recovering archived data

After the history log cleanup, Control Center stores the archived data in Access database files. The archived
data is no longer directly visible in the History tab. If you want to make the archived data visible again, your
Control Center allows you to recover the history data from the archive Access database files.

The recovery procedure imports the archived data back to the Control Center database and makes the data
available for viewing and further analysis.

NOTE
Use the archived data recovery option if you plan to conduct an audit that requires checking
the already archived data stored in Access database files.
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1. To recover the archived data, run the dedicated Archive Importer application that you
can find in your Control Center installation folder. The default path is: c:\Program
Files\NiceLabel\NiceLabel Control Center\Utils\ArchiveImporter.exe.

2. Click Import. The file browser window opens.

3. Locate your Microsoft Access archive database file. If your archive uses separate database files
with time stamps, make sure you select the file for the relevant time period.

4. Click Open. Your archive data becomes visible again in the Control Center History.

Because reimporting the archived data adds load to the Control Center database and slows down the
performance, you can delete the recovered data after you are done with the audit. To delete the recovered
archive data, click Delete.

NOTE
During the archive data recovery, your Access database files remain stored on your
computer. If you decide to delete the recovered archive data from your Control Center,
you still keep the original Access database files and all history data that is visible on the
History tab.

The recovered archive data is excluded from the data archiving in Control Center. The recovered data
remains visible on the History tab until you delete the data using the Archive Importer application.

10.2. Database Replacements

Database replacement lets you change database connections for your labels, solutions, and Automation
configurations when switching between multiple database servers.

Database replacements enable you to configure solutions in development environments and run those
solutions in production environments without any database configuration changes inside the solutions.

NOTE
To configure database replacements, you must log on to Control Center as an
Administrator.

Database connection string replacements let you configure solutions where parts of database connection
strings change while solutions run with connected databases. After running database connection string
replacements, your solution still uses the unchanged database configuration, but with a connection to a
different database server.
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You can use the database replacement option with all types of databases:

• SQL

• Oracle

• MariaDB / MySQL

• Access

• Excel

• CSV and other text files

NOTE
Database replacement is possible with solutions and configurations that run in NiceLabel
Print, NiceLabel Web Client, and Automation.

Configuring database replacements define your "from-to" replacement pairs. Each replacement pair
contains Value from and Value to elements. During actions, Value from strings becomes Value to strings.
The number of replacement pairs is not limited.

1. To add new database replacements, open Control Center and go to Administration > Database
Replacements.

2. Click Add+. The Database replacements page opens.

3. Type the Replacement name. Make the name descriptive so you can easily find the replacement
later.

4. The Find text field lets you search for the existing From element of the replacement pair. This is the
database connection string you are replacing.

5. Type Replace with. This is the <To> element of the replacement pair. This is your final database
connection string.

6. Click Save. Your new replacement is active and listed on the Data replacement page.

NOTE
After you click Save, database replacements require up to 10 minutes to take effect.

Example

Your action in Automation connects to mySQLServer and myDatabase. You want to update your
database connection string to use the database NEW_myDatabase on the server NEW_mySQLServer.

You must define two replacements – the first changes the server name, and the second changes the
database name.
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1. Add the first replacement and name it Server name replacement.

2. Type in the Find text field: Data Source=mySQLServer

3. Type in the Replace with field: Data Source=NEW_mySQLServer

4. Add the second replacement and name it Database name replacement.

5. Type in the Find text field: Initial Catalog=myDatabase

6. Type in the Replace with field: Initial Catalog=NEW_myDatabase

NOTE
All database replacements are encrypted in the Control Center database. This ensures
the secure replacement of sensitive data, such as user names, passwords, and network
addresses.

Database replacement ensures that your solutions and configurations connect to the right databases both
in a test environment and in production.

10.3. Global Variables
Global variables are label or solution variables that you share among multiple printing applications and
label printing clients.

You can use global variables as unique counters. When several clients print labels with a shared counter,
you prevent duplicating of counter values by using the same global counter with all printing clients.

You can also use global variables to set values that change only occasionally.

NOTE
Use global variables if your solutions don't have database connections. Using database
values is more practical than using global variables.

Each global variable has a unique internal ID number. This number identifies the global variable within a
solution.

You can create global variables in Control Center or in Desktop Designer. After you design your labels or
solutions that use global variables, you must define which global variables are you going to use. Desktop
Designer can either work with global variables that are stored locally in the Globals.tdb file, or with
global variables stored in Control Center.

To select the right source of your global variables in Desktop Designer, go to File > Options > Global
Variables.
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NOTE
To use the global variables from your Control Center, make sure Desktop Designer and
Control Center are connected.

You can manage your global variables in Control Center, if you go to Administration > Global Variables. Use
icons to add, edit, or delete the global variable.

NOTE
You can't delete Control Center global variables in Desktop Designer.

The settings and terms at global variables are the same as in Desktop Designer and apply mostly a to
counter. Check Desktop Designer User Guide for more details.

10.4. Email Alerts

Email Alerts enable you to automatically send detailed information about errors in printing or in
applications. You can send emails to any email address, even if the recipient is not Control Center user.

With email alerts, you send information about:

• Errors in printing labels from Desktop Designer, Print, or Automation.

• Control Center errors.

• License violations (exceeded number of available printers).

• Printer errors.

You can configure, edit and manage Email Alerts if you go to Administration > Email Alerts.
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NOTE
If there are multiple identical label printing errors, Control Center doesn't send alerts for
each of these errors. In case of repeating printing errors, you receive a new alert every 15
minutes.

The 15-minute alert delay only happens if you are continuously printing identical label
files using the same printer. If you change the label file or printer, you receive an alert
immediately after your computer reports an error.

Adding new alerts

Go to Administration > Email Alerts and click Add. Create New Alert wizard opens.

1. In DEFINE ALERT step enter Alert description. This is the name of your alert that will display on the
list of alerts.

2. By clicking into the Alert type filed you can add or remove alert types that will generate and send
emails.

3. If you disable the All workstation setting, you can type only the workstations that you would like to
monitor for alerts.

4. Click Next: Alert Content.

5. Define the Email subject. You can include your text and one or more of the provided alert
information into the email subject using brackets. For example, [Module], [PrinterName], or
[ErrorType].

6. Define the content of the email (Email body). By default, all the available information is included in
the Email body. You can delete any of the lines and edit the introduction text.
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7. Click Next: Sender & Recipient.

8. Define the email address of the sender and add recipient emails. Here you can also disable the alert
and enable it later by editing the alert.

9. To test your alerts, you can send a test email to a recipient that can be the same or different from
the members in the Recipient emails list.

10. Click Create alert.

Your alert is created and added to the list of alerts. If you click on your alert, you can edit the settings and in
the last step Save changes.

To delete your alert, click the checkbox at the alert, then press the Delete button. A window opens to
confirm the delete operation.

When an error occurs, Control Center sends an email to the recipients that you defined in SENDER &
RECIPIENTS window.

Additional alerts options

To use additional options with your alerts, select one or more alerts by clicking the checkboxes, then press
More button:

• Duplicate alert. If you want to create a similar alert to the existing one, you can duplicate the existing
one and modify it. Modify your duplicated alert by clicking on it.
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• Send test alert. You can send a test alert directly by clicking this option. You don't have to open the
alert settings window to send the alert.

• Enable alerts or Disable alerts. While creating your alerts you might disable them. You can change the
Enable or Disable statuses directly by clicking the options. You don't have to open the alert settings
window to change the statuses.

SMTP settings

To successfully configure your email alerts, define your email server SMTP settings. Click the SMTP
settings button to define:

• Server name

• Port number

• Username

• Password

• Sender email and name

To verify SMTP settings, you can send a test email.

You can also use Gmail or similar third-party email providers. In this case, Port number is mandatory and
Secure connection must be enabled.

Detailed procedure for sending alerts over external mail servers is available in our knowledge base article.

184

https://help.nicelabel.com/hc/articles/4405121437969-Using-3rd-party-SMTP-to-send-notification-emails-from-NiceLabel-Control-Center


Your alerts are now configured. Once an error occurs, the alert sends a notification to the specified email
addresses, and the alert event is logged in the History section. For more information on the event log, see
the History section.

NOTE
If users don't receive email alerts, they should check their Junk Email folders.

10.5. Synchronization

Synchronize your files in the Documents repository on your master Control Center with your client Control
Center instances. Your client Control Center instances update Documents repositories with the exact
copies of published files and folders from your master Control Center.

NOTE
You can synchronize your master LMS with your Loftware Cloud only if LMS is accessible
via the Internet.

Use Synchronization for the following purposes:

• Synchronization of files on geographically distributed locations. Your master Control Center is
located in your company's HQ. You store your label designs and manage your approval process in
Documents storage in the master Control Center . When you approve and publish the labels, you
distribute the labels to remote production environments. All remote Control Centers are set as clients
to the master Control Center.
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• Synchronization of files of multiple-stage deployments (development > test (Quality Assurance)
> production). Your files follows the chain process from the development towards the production
environment. Control Center in the Development environment is master to Control Center in the
Test environment and Control Center in the Test environment is master to the Control Center in the
Production environment.

NOTE
When the synchronization is enabled, the Documents repository in the client Control Center
switches to read-only mode. You can't add or remove folders and files in the client Control
Center . You can change workflow types for folders and change workflow steps for the files
within these folders. You can also delete files from the replicated Documents repository.
Your deleted files get synchronized from your master Documents repository in the next
synchronization interval.
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IMPORTANT
If you delete your files on the master server, these files are not automatically deleted on
client servers. To prevent errors in production with client servers, you must delete the files
from client servers manually.

10.5.1. Enabling Synchronization

First, generate the security key on your master Control Center:

1. Open your master Control Center page.

2. Go to Administration > Synchronization.

3. Click Generate key.

To enable the synchronization on your client Control Center:

1. Open the Control Center page and go to Administration > Synchronization.

2. Enter the security key (token) generated on your master Control Center.

3. Enable Synchronize Document Storage from another Control Center server.

4. Adjust Synchronization Settings and Synchronization Scheduling.

NOTE
Document Storage is read-only option: If enabled, this option makes the replicated
Documents repository operate in read-only mode. The synchronized folders and
included documents can't be modified. To allow adding additional folders or files to
the replicated Documents repository, disable this option.

5. You can define Synchronization Settings if you slide the Synchronize Document Storage from
another Control Center server switch.
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NOTE
Source Control Center server URL syntax is different for LMS and Cloud editions.

• In LMS editions use the syntax:
http://server/EPM

where server is the name of your LMS server.

• In Cloud editions use the syntax:
http://account.onnicelabel.com/dashboard

where account is the name of your Label Cloud account.

6. Click Save.

You can disable synchronization if you deselect Synchronize Document Storage from another Control
Center server.

10.5.2. Logging Synchronization Activity

After each synchronization cycle, the information about sync action is added to the System event log. The
report contains the following information:

• Start time of sync.

• End time of sync.

• The list of synchronized files (file name, revision).

10.5.3. Synchronization Rules

These are the main rules that the synchronization procedure follows:

• Clients always initiate and configure the synchronization.

• You have to provide the security key that matches the security key on the master Control Center. The
security key allows access only to the authorized clients. You can click the Generate Key button on
the master Control Center to generate your security key, or type in your custom string of characters.
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• You can only synchronize files that are part of the workflow process.

• The files that are in the final step of the workflow selected for the particular folder will be
synchronized. The final workflow step is usually approved or published. This depends on your
selected workflow.

• When your source files are synchronized on the client, your files on the client are placed in the initial
state of the workflow which is defined for the folder on the client. The workflow process for the folder
on the client can differ from the workflow process on the master.

• The file revision number is also synchronized. When the file in revision 10 on the master is
synchronized with the client, it will retain revision 10 also on the client. Because not all revisions
are approved/published, you can expect to have gaps in the revision numbers on the client.

• File decommissioning makes obsolete published files unavailable for read-only users. When the client
Documents repository synchronizes with master Control Center, the decommissioned approved files
are copied from the master Documents repository but are no longer marked as decommissioned
in the client Documents repository. To make these files invisible for the read-only users also in the
client Documents repository, decommission them manually. To learn how to decommission a file, see
section Specific access permission options.

• Synchronization service periodically retrieves the list and states of files on the master and compares
them with client copies. New files, files with higher revision numbers, and files that have reached the
final state in the approval process will be updated in the replicated Documents repository.

• Synchronization uses its own authentication method and bypasses the authentication mode
configured in the master Control Center. All data exchange is encrypted.
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